Scientific Linux 6 64bit - garbage from Ethernet Shield

What magic have I missed it trying to get Arduino to work properly on this Linux version? or Linux in general?

It seems to work fine until I try and use the Ethernet shield where all I get back from sample programs for telnet or the web server is garbage even though the upload appears to have completed properly.

So last night I fired up my Windows 7 vm running in Virtual Box on this same host and it compiled and uploaded the samples properly and now from the host box I can telnet to the Ethernet shield and get proper responses.

Clearly something is incorrect but the Windows 7 test eliminated any hardware or cables so it must be a software problem of some kind so where do I start looking?

I suspect that it is related to rxtx somehow but since there is so much conflicting information I thought I would just ask for help instead of spending the next week experimenting and getting more frustrated.

Thanks Bill KT7V

Since no one else has answered I will give a shot. Show and tell me what you are doing. Details count.

Thanks for taking a shot .... I am sure this is Fedora / Red Hat specific as I can find all kinds of information on getting Ubuntu working but with all kinds of conflicting Fedora / Red Hat information it leaves me concerned. But you asked for details and there isn't much and no magic involved

Basic generic pc with a quad core 2.4 Ghz processor and 8GB Ram and 6800xt video card running SL6 64 bit.

Stock Adruino 022 Linux install using Open Java 1.6.0 with the library as shipped with Arduino 022.

To generate the failure: Open a example project say for example the ethernet web server that displays the analog inputs and compile it and upload it to ttyACM0 and everything is successful. Now open a browser and point it at the address of the ethernet shield and you get either nothing or a screen of garbage. Tried resets as per some hints on the forums .. no joy

But run the same compile on either a windows Xp or 7 Virtualbox vm after of course installing the Arduino 022 code and usb drivers and now you get the desired screen and better than that you can now open a browser on the SL6 box and get the proper display too???

Clearly these VM's are using the shared usb connection as a pass through and being able to access the page from the native box tells me that somehow the compile / upload on the SL6 box is not working properly.

Tried other cables and usb ports of course and no change in behavior not that I would have expected any. Trying to use links to the native libraries in SL6 instead of the ones supplied by Arduino breaks everything so nothing talks at all. As does trying to use the SL6 provided avrdude instead of the Arduino provided one.

Just as a test I tried installing Arduino on my 32 bit Acer Netbook running Fedora 12 and got the exact same problem so more than ever I am convinced that there is something in the core Red Hat / Fedora distros that Arduino just doesn't like.

I guess the next test is to fire up a Ubuntu instance and see if that changes anything since there are significant differences between debian and redhat at the kernal level.

One note here: I can successfully compile and upload code from SL6 and get it to run if it doesn't need to talk to the ethernet shield, in other words building up sample code to talk to a 4 line lcd display works just fine. Since the pins I choose for the LCD conflict with the Ethernet Shield I can not try them at the same time but I would expect it not to work based on the previous experiments. A test I will have to do sometime in the near future.

Another note: Since the original tests I have purchase an Arduino Mega 2560 R2 ( since what I ultimately want to do needs more i/o pins ) and I can duplicate the exact same failures and successes so processor board makes no difference.

Thanks in advance for any insights Bill KT7V

I’m using Ubuntu Linux 11.04 (32-bit) and it seems a little touchy, where occasionally I get an error on upload and I have to do it again. Sometimes the layers in the menu stop showing and I have to restart arduino IDE.

You could try using Eclipse as an IDE and bypassing it all together. Or you could try and compile it yourself with a makefile and upload it via the commandline.

Interesting that Ubuntu 11.04 is giving you occasional issues as Ubuntu seems to be favored as a linux distro by this project.

I did try spinning up a 10.04 desktop in a vm and could not get the serial port to work out of the box and yes I think all the permissions and right stuff is installed, it wasn't a priority so I have not spent a ton of hours on it.

So I moved on to using the windows vm's which do work.

Dynamic devices have always been a problem in linux and usb is one of the worst, so on some level I am not shocked that it doesn't work. I just found that the specific failure mode I experienced was something identifiable and maybe fixable.

Yes eclipse is where I am heading but I expect that too to be a long road with many bumps but at the end of the trail will be the ability to do development for these processors without a dependence on windows.

I will keep monitoring this post on the off chance someone can provide an answer but in the mean time thanks to all who replied to my post.

Bill KT7V


I need help also! I have an Arduino MEGA (ATmega 1280) connected to a SL6 machine, on 64bit. I wrote an script to share ASCII words between the OS and the Arduino Board, but this doesn't work. I have the chance to test it under Windows7, Windows XP and Ubutnu (works in all of them), but this script must work on SL6. The script that I wrote that comunicate with Arduino is wrote on C++.

If there are a way to test port, configure some how or anything else in order make this work, I will be very happy if some one want to share this usefull ideas with me.

Thanks.- alan888

I had a problem like this with my ethernet shield and an EtherTen board which turned out to be caused by having updated my avr tool chain on my linux box to a newer one. I reverted the toolchain back to the older versions that were supported by apt (this is on Ubuntu 10.04) and suddenly my sketches worked and the ethernet data was sane again.

These are the package versions I'm running now: avr-libc: 1.6.7 binutils-avr: 2.20-2 gcc-avr: 4.3.4-1