SD Card module - fails to work with Mega

I have tried three SD modules (cheap Chinese no name) two with six pins and one with a 7th 3.3V pin.

None of the examples in the SD library can initialize any of the modules and report "Initialization failed!" which is the condition SD.begin(4) == 0. I have checked the wiring connections to the Mega multiple times. I have also swapped the MISO/MOSI. No LED (if any) lights on the module.

The pins are the driver defaults 4 CS, 11 MOSI, 12 MISO, 13 CLK .

I understand that these modules operate at 3.3V, but also accept a 5V MCU, as they have a VCC pin, and the description appears to say it will work with any Arduino. They come with a LDO regulator. Link is to the description of the module. Any help will be greatly appreciated.

Have you tried them on an UNO to confirm they work okay?

On the Mega the SPI pins are different...
MISO = pin 50
MOSI = pin 51
SCK = pin 52
CS = pin 53

1 Like

WOW! Pins 50 thru 53 worked. Thanks muchly.

I had seen that somewhere but had completely forgotten about it. Thanks for the reminder!