SD Card Not Initialising?

Hi all,

I'm trying to get an SD card module working with an Arduino Uno, but I've run into a few issues. I've followed this tutorial: Guide to SD Card Module with Arduino | Random Nerd Tutorials, however whenever I run the SDCardInfo sketch, all I get is an error message listing things to try. All of which don't apply, as I have tried (i.e. wiring is correct, card is inserted, and I'm using the CS pin defined in the sketch).

On top of this, I have also tried:

  • Plugging the SD card module directly into the Arduino pins
  • Using alligator clips and breadboard wires to connect the SD card module into the Arduino pins
  • Tried using a different MicroSD card
  • Tried using a different MicroSD card adapter
  • Powering the SD card module & Uno from a 5v supply

All of these met with the same result. Below is the module I'm using, and how I have it wired up:

The two MicroSD cards I've tried in the adapter are 8GB and 16GB cards, which were formatted for FAT32 (Quick Format) under Windows 7.

Am I missing something, or could I have a faulty module?

I'm having similar problems (as described in another thread), but have you tried the SD Card Formatter app instead of using Win 7?

See the pinned topic: Don't Format SD cards with OS utilities! - Storage - Arduino Forum

I just started a new thread about a possible explanation.

But other than that, do you have a way to check that 3.3V is being delivered to the Vcc pin of the SD card (from the voltage regulator on the module)?

I've got it working now. I formatted the 8GB card with the formatter program, and tried it. The first time I ran the CardInfo sketch, it said it couldn't find the partition. After that, it worked correctly every single time, even after I put some files on it to test.

It also didn't help that one of the MicroSD-to-SD card adapters didn't work.

If your SD module works, then I'm wrong about that type of module being the problem. Oh well.