SD Card not working with logging shield

Hi

I am midway through a project where I am required to log data from an accelerometer to an SD card (I'm of mechanical discipline so go easy on me please!).

I have managed to get a serial output from the accelerometer so that is not an issue.

The data logging shield I am using is this one (Rev B) which came recommended by colleagues and online. Using a 16GB class 10 microSDHC (w/ adapter), formatted using the SD formatter utility to FAT32. The chip select pin has been set to 10 as recommended in the adafruit docs, though I have tried 4 and 8 aswell just in case.

Initial tests have not gone well. Using the CardInfo sketch in the SD library I get the following output:

Initializing SD card...initialization failed. Things to check:
* is a card inserted?
* is your wiring correct?
* did you change the chipSelect pin to match your shield or module?

From searching on this forum I found recommendations to use the SdInfo sketch from the SdFat library available online, for a more descriptive error. This produces the following output:

SdFat version: 20160719

Assuming the SD is the only SPI device.
Edit DISABLE_CHIP_SELECT to disable another device.

Assuming the SD chip select pin is: 10
Edit SD_CHIP_SELECT to change the SD chip select pin.

type any character to start

cardBegin failed
SD errorCode: 0X1
SD errorData: 0X0

And the QuickStart sketch in the same library:

SPI pins:
MISO: 12
MOSI: 11
SCK:  13
SS:   10

Be sure to edit DISABLE_CHIP_SELECT if you have
a second SPI device.  For example, with the Ethernet
shield, DISABLE_CHIP_SELECT should be set to 10
to disable the Ethernet controller.

SD chip select is the key hardware option.
Common values are:
Arduino Ethernet shield, pin 4
Sparkfun SD shield, pin 8
Adafruit SD shields and modules, pin 10

Enter the chip select pin number: 10

Assuming the SD is the only SPI device.
Edit DISABLE_CHIP_SELECT to disable another device.

SD initialization failed.
Do not reformat the card!
Is the card correctly inserted?
Is chipSelect set to the correct value?
Does another SPI device need to be disabled?
Is there a wiring/soldering problem?

errorCode: 0x1, errorData: 0x0

Restarting

From reading other posts it is apparent that this does not necessarily indicate a dud SD card, but none of the posted solutions have worked for me. Are there any glaring errors or oversights that I am missing? Any assistance is much appreciated.