SD card not working

Running CardInfo it gives inititalization failed message. What do I need to do?

Arduino UNO, datalogging Arduino shield RevB, i2cbusScan found on 0x68, RTC works, can read the 32 Mb SD card with PC.

I tried chipSelect = 4 & 10, tried jumping digital 10 to digital 4

Here is CardInfo program (exactly the same as the SD example)

  SD card test

  This example shows how use the utility libraries on which the'
  SD library is based in order to get info about your SD card.
  Very useful for testing a card when you're not sure whether its working or not.

  The circuit:
    SD card attached to SPI bus as follows:
 ** MOSI - pin 11 on Arduino Uno/Duemilanove/Diecimila
 ** MISO - pin 12 on Arduino Uno/Duemilanove/Diecimila
 ** CLK - pin 13 on Arduino Uno/Duemilanove/Diecimila
 ** CS - depends on your SD card shield or module.
 		Pin 4 used here for consistency with other Arduino examples

  created  28 Mar 2011
  by Limor Fried
  modified 9 Apr 2012
  by Tom Igoe
// include the SD library:
#include <SPI.h>
#include <SD.h>

// set up variables using the SD utility library functions:
Sd2Card card;
SdVolume volume;
SdFile root;

// change this to match your SD shield or module;
// Arduino Ethernet shield: pin 4
// Adafruit SD shields and modules: pin 10
// Sparkfun SD shield: pin 8
const int chipSelect = 10;

void setup() {
  // Open serial communications and wait for port to open:
  while (!Serial) {
    ; // wait for serial port to connect. Needed for native USB port only

  Serial.print("\nInitializing SD card...");

  // we'll use the initialization code from the utility libraries
  // since we're just testing if the card is working!
  if (!card.init(SPI_HALF_SPEED, chipSelect)) {
    Serial.println("initialization failed. Things to check:");
    Serial.println("* is a card inserted?");
    Serial.println("* is your wiring correct?");
    Serial.println("* did you change the chipSelect pin to match your shield or module?");
    while (1);
  } else {
    Serial.println("Wiring is correct and a card is present.");

  // print the type of card
  Serial.print("Card type:         ");
  switch (card.type()) {
    case SD_CARD_TYPE_SD1:
    case SD_CARD_TYPE_SD2:

  // Now we will try to open the 'volume'/'partition' - it should be FAT16 or FAT32
  if (!volume.init(card)) {
    Serial.println("Could not find FAT16/FAT32 partition.\nMake sure you've formatted the card");
    while (1);

  Serial.print("Clusters:          ");
  Serial.print("Blocks x Cluster:  ");

  Serial.print("Total Blocks:      ");
  Serial.println(volume.blocksPerCluster() * volume.clusterCount());

  // print the type and size of the first FAT-type volume
  uint32_t volumesize;
  Serial.print("Volume type is:    FAT");
  Serial.println(volume.fatType(), DEC);

  volumesize = volume.blocksPerCluster();    // clusters are collections of blocks
  volumesize *= volume.clusterCount();       // we'll have a lot of clusters
  volumesize /= 2;                           // SD card blocks are always 512 bytes (2 blocks are 1KB)
  Serial.print("Volume size (Kb):  ");
  Serial.print("Volume size (Mb):  ");
  volumesize /= 1024;
  Serial.print("Volume size (Gb):  ");
  Serial.println((float)volumesize / 1024.0);

  Serial.println("\nFiles found on the card (name, date and size in bytes): ");

  // list all files in the card with date and size | LS_DATE | LS_SIZE);

void loop(void) {

Is it the same as the Adafruit version? If so, try reading their tutorial.


jgolden: Running CardInfo it gives inititalization failed message.

Which message? Knowing at which stage the process fails, we can give you more accurate solutions.

Thats what I've been using, the online tutorial. Is there a hardware connection I need to make that is not discussed in the Adafruit tutorial?

Error message - is not a compile or board communication message. It is from the program. The program I posted is called Cardinfo. When the command "card.init(SPI_HALF_SPEED, chipSelect)" fails, it writes a message saying "initialization failed. Things to check:" The message can be re-written to say anything, so what it says is not important. Thanks!

see if reply #2 in is useful

Thanks, but no. There is already a chipSelect=10 in the program, so I added the pinMode command to the setup section before the card initialization. Still gives the error.

Problem solved. It appears the older Arduino UNO board SMD R2 needs the logger shield to have solder bridges SCL and SDA shorted (I believe they go to pins A4 & A5). I was using that logger shield on a newer UNO. When I un-soldered those, it worked.

Check the Shield's 3.3V output, if the voltage is below 3V the SD card detect will report error. Connect 3.3V using a jumper wire. that should solve the issue.

The CardInfo sketch (example) works on the UNO but not on the Nano 33 IOT, which fails to initialize. The Nano runs at 48MHz, 3x faster than the UNO. Any suggestions?

The SD reader is on a Touch Screen