SDA Y SCL Nodemcu

Buenas tardes, he conectado una LCD con un modulo I2C y un RTC I2C al nodemcu. Al energizar el circuito la lcd solo muestra la palabra iniciando. He estado buscando en la web sobre este problema pero no he encontrado. El lcd debe mostrar un menu, pero solo muestra la palabra iniciando. No estoy segura, pero creo que tiene que ver algo con que ambos componentes compartan los pines. He buscado sobre los pines y dice que se emplean como multimaestros. Pero no le encuentro solución a este problema.

LCD 16X2
RTC I2C: DS1307
![WhatsApp Image 2021-05-26 at 10.40.32 PM|281x500]
f2bc22d46c4ef5e8a04402f358c9d2c1f59f3f05_2_281x500

¿Y si nos compartes el código que estás usando? (Por favor hazlo correctamente, fíjate en las Normas del foro la manera de hacerlo)
Lo mismo qué módulos RTC y LCD usas, y en lo posible las conexiones.
Cuanto más datos aportes más rápido se hallará la solución (sino es adivinar).

Saludos

Hi,
Ese problema se debe a la libreria que estas usando. El problema es que la libreria responde con un zero en vez de un 1 . Trata de conseguir otra liberia. En este link explican el problema.

https://github.com/johnrickman/LiquidCrystal_I2C

Hi,
Aqui esta el link donde explican el problema.

https://forum.arduino.cc/t/lcd-16x2-problem-only-one-character-per-row/354420

@tauro0221 Dice que le muestra la palabra "Iniciando", no el primer carácter solamente.

Seguramente es un problema de código pero nunca lo subió para poder verlo. En fin... Ya lo habrá solucionado.

Saludos