Seeing Yun in IDE Port menu

My new Yun arrived yesterday and I'm just getting started. I've mucked around with Arduino a couple of years but not so much with Linux.

The Yun has been configured as per the getting started guide to connect to my wireless network. I can ping it from my development PC as well as SSH into it. If I connect the Yun via USB I can program it OK. I've currently tried out the 'console' sketch in the getting started guide. If I SSH using Putty and then Telnet into localhost it works perfectly.

What I can't see is the Yun coming up in the IDE Port menu which should allow me to use the port monitor as well as program the Yun wirelessly. The only thing the guide say they must be on the same network which they surely are.

I'm running IDE 1.5.4 on a Windows 8 laptop connected wirelessly to my network. I'm sure I'm just missing something simple in the setup.

Dave

Hi

Could this be related with some firewall/antivirus settings? (Do you have an antivirus? Which one?)

Can you check if port 5353 UDP is blocked?

Norton 360 which I installed some time ago.

Added a new traffic rule allowing to/from traffic from any computer on the same subnet using UDP and remote port 5353
Now works as expected. The Norton 360 rules make it hard to see what is what as they use some fancy GUI and you have to burrow down each rule.

An even simpler way was to add a rule to Norton 360 for arduino.exe to allow traffic to/from any computer on the same subnet using TCP & UDP on any port local or remote.

Many thanks for pointing me in the right direction Federico.

Dave

Really happy you've found out the reason! I'll remember this post for the users to come

Hi, I'm seeing a similar issue in OS X IDE, the yun is not listed in ports.

I've checked firewall settings and can see that Arduino 1.5 allows incoming connections.

Like the OP, SSH sessions are fine and the web admin is working as expected.

Any ideas?

Try running the wifistatus example: are the Yun and your mac on the same network? (like both on 192.168.10.x with a different x for each of them?) Just in case: the port needed by the IDE to show the yun as a "network" port is 5353 UDP

I've also found that very often the Ports menu is not refreshed when clicked and displayed. Usually, the menu is updated in the background somehow, and then shows the actual available Ports after opening the Ports menu for a second time. Think this is a bug in the Beta Arduino IDE.

The port menu is updated in two different ways: serial ports are updated every time you open the tools menu, network ports (ip addresses) are updated in background
That’s a requirement due to the way the IDE discovers available yuns on the network.

If you want to go deeper: protocol is called ZeroConf and has two implementations, one from Apple called Bonjour (also available on Windows) and one for Linux called Avahi. It uses port 5353 UDP. A yun announces itself on the network broadcasting a packet, and it does that like every one second. UDP doesn’t have any ways of acknowledging the reception of that packet. So the yun acts as a lighthouse: sends signals of its presence, hoping for something to listen, but never knowing if something actually listened

And FYI the IDE uses a pure java (so cross platform) implementation called jmdns

I have disabled the antivirus and the windows 7 firewall but still IDE can see my arduino YUN. I can ping it, I can be connected with it via usb and telnet via IP and it is on the same network with the pc.

Can I manually add my arduino yun IP at the IDE port menu?

Currently, no. Can you add an issue on the IDE github? https://github.com/arduino/Arduino/issues?state=open

My 2 cents;-

Yun in IDE Port menu need to meet 2 conditions: 1. Yun Bonjour service is working. 2. Windows' UDP port 5353 is open.

Download Bonjour Browser first.

http://hobbyistsoftware.com/bonjourBrowser

If Arduino no show, please reinstall Bonjour for windows.

  1. From the Start menu, select Control Panel.
  2. If you are using Windows XP, double-click Add / Remove programs.
  3. If you are using Vista/Windows 7/Windows 8 , double-click Programs and Features.
  4. Locate Bonjour list, select it and click Remove.
  5. In a Web browser, access the site http://support.apple.com/kb/DL999
  6. Download and install Bonjour for Windows on your Windows system.
  7. You will be prompted to install on a desktop shortcut to the wizard for adding a printer.
  8. If you choose No, you can still access the wizard.
  9. Click on All Programs.
  10. Select Bonjour, Bonjour Printer Wizard and then choose from the menu.

after confirm Bonjour is working restart arduino IDE.

Problem solved after installing Bonjour Browser 2 times.

Thank you very much for your support.

The Arduino IDE itself is written in Java, and it can communicate to the Arduino via the Java library. Sometime you need reinstall Java runtime as well as Arduino IDE.

  1. From the Start menu, select Control Panel.
  2. If you are using Windows XP, double-click Add / Remove programs.
  3. If you are using Vista/Windows 7/Windows 8 , double-click Programs and Features.
  4. Locate Java list, select it and click Remove.

Manually download and install Java for my Windows computer

Java Downloads for All Operating Systems

  1. Locate Arduino list, select it and click Remove.

Download the Arduino Software

hi there, i have discovered that this issue is particularly problematic when the wifi signal is "weak" or average at best (like 2 bars), can anyone verify this? on stronger signals (3-5 bars) i don't encounter this problem of not seeing the YUN ip address in the IDE Ports menu.

i have concluded that it is indeed an IDE problem because i can ping the YUN's ip add as well as connect to it via the browser but no such luck with the IDE, i'd have a hard time uploading sketches to it.

i hope there is a way to resolve this. sonnyyu, i have done everything you instructed but no improvement :(

First test the system with ethernet connection. If it works then wifi is the problem. Second since Yun use Wifi 2.4 Ghz, it could be very crowd, use android phone/pad by play store download application wifi Analyzer. Then find out unuse channel switch to. ( at your router)

http://forum.arduino.cc/index.php?topic=203676.msg1503265#msg1503265

To confirm wifi Signal level: at linino console;-

/usr/bin/pretty-wifi-info.lua

where give you wifi info

Current WiFi configuration
SSID: TP-LINK_2.4GHz
Mode: Client
Signal: 100%
Encryption method: WPA PSK (CCMP)
Interface name: wlan0
Active for: 28 minutes
IP address: 192.168.0.103/255.255.255.0
MAC address: 90:A2:DA:F0:06:76
RX/TX: 914/268 KBs

or you could use Arduino IDE, at Example->Bridge->WiFiStatus upload Sketch then open serial monitor to view.

Sometime you will have difficulty to access Arduino via "http://arduino.local/" even Arduino is working fine at ip address. in other word you could access Arduino via http://ipaddressofarduino/. To find out ipaddressofarduino:

Using android phone/pad via play store download application Bonjour Browser. It will give you Arduino IP address.

An other way to get ip address of Ethernet via arduino ATmega32u4 sketch.

Arduino IDE->Examples->Bridge->YunSerialTernimal, upload it to ATmega32u4, open Arduino IDE-> Tools->Serial Monitor, then type "~2" ( without quotation marks) , You will get Linino console. type "ifconfig" ( without quotation marks) to get all the ip address.

To reset Yun back to factory default, type "/usr/bin/reset-to-factory-anyway" ( without quotation marks). at Serial Monitor

During Wifi setup stage the wifi Signal level might not be stabilize. Disable wifi-live-or-reset might help.

nano /etc/rc.local
#wifi-live-or-reset
exit 0