Sending ctrl+z using serial monitor +7020g

Hi,

I am using Arduino UNO in combination with M5 STACK + SIM 7020G(NB IOT). I am trying to send a message using Arduino serial monitor and have a trouble in ending the message. Ctrl+z is not working on serial monitor. I tried ending the messages in several ways but nothing works except using "" and it returns error. In the below example after entering hello, i tried couple of times pressing ctrl+z or esc, nothing works.
AT+CMGS="+467000000"

hello.

ERROR
at

OK

br,
anvup

show us your code…

@anvup1, your topic has been moved to a more suitable location on the forum.

Maybe there is some information in arduino control z - Google Search

As i am sending AT commands individually on serial monitor i dont need any code, dumping a sample or demo code is enough.

If you’re not using any code, why bother using Serial Monitor ?

It’s a very restrictive imitation of a terminal program…

Try PuTTY or another ‘real’ terminal package.

i tried putty as well and still have the same issue. upon doing ctrl+z, i get and error instead of confirmation.

It’s beginning to sound like your modem isn’t connected to the network.

Try setting up to receive messages
AT+CNMI=2, 2

Then send a message to the modem…
You should see incoming notifications..

Then try sending a text followed as expected with CTRL-Z (0x1A or 26 decimal)

There’s a chance if you can receive, but not send, the SIM plan has no credit.

i got the response ok upon sending
AT+CNMI=2,2
But after sending the message and entering ctrl+z i got the reply "error"
i am using post paid does it have any impact? and when i use at+cops=? i got reply error instead of service provider name

Did I suggest sending ctrl-z ?
I suggested send an sms (from your phone) to see if it receives incoming messages.

OK. I tried to send the message and not received anything on the modem.

ok, that suggests the modem isn’t online…

Just while we’re here…
When you apply power to the modem, do you get any startup text from the modem?

I assume your SIM doesn’t have SIM PIN enabled… ?

How about typing
ATI carriage return ?
AT+CCINFO carriage return ?

The response from putty is as follows.
ATI
SIM7020G R1910
OK
AT+CCINFO
ERROR

But i also got this,

AT+COPS=?
+COPS: (3,"TELIA MOBILE","TELIA","24001",9),,(0-4),(0-2)

OK