sensor shield connection kicks off serial port?

Dear Arduino Tinkerers,

when I connect an actor (motor, LED) to a digital pin via Sensor shield v.2 (Tinker it) the actor is running but I cannot switch it off inside the maxuino patch and the serial port is disconnecting (from the rigth port com 3 to com 1). I few hours ago all was running Ok, but when I pulled out the USB cable while running the motor after that motor is always running when I connect it to the sensor shield. When I connect the actor directly via the Uno (e.g. one wire into pin 3, one into GND) all works as it should. But why not with the sonsor shield?

Similar situation when using a touch sensor or push button

I tried resetting the Uno, the serial port, restarting the pc but nothing changes. I do the same as before to elect the pin/digital out in the Pin Modes subpatch.

I am working with Win 7 (32 bit), Arduino Uno , Max/maxuino respectively a simplified patch from

Perhaps a stupid mistake but as a beginner with Arduino after reading through trobleshooting chapters and trying fixing this for hours I would be glad about an advice.

Geko, I'm really not sure what's happening here. Two possible? hints:

  • Go back to the simple BLINK program and change it to blink pin 3. See if it works directly on arduino, then thru Sensor Shield. If that's OK, them something else is going on??

  • Unplugging the USB while running has caused some problems with the new USB chip on some Arduinos. Maybe related??

The symptom where you first show both COM1 and COM3 and later only COM1 means your USB communications has been stopped somehow. How could the Sensor Shield affect this?? Try an external power source, like 9V to the external power connect.

Hmmmm ..??

Thanks terry King for your answer!

when I upload the simple blink sketch as you recommended and putting 2 wires in pin 3 and gnd then the LED blinks correctly.
when I do the connection to the sensor shields pins the same behaviour (correct)
when I do the connection with the LED by the sensor shields white plug in locations (see foto attachment, how do you call them correctly?) then the LED glows permanently (without break). The same behaviour when I connect the LED to any other input or output plug in location on the shield.

With external power supply (4,5 V) same behaviour.

I can later see if there are related articles in the forum for the “unplugging usb while running” story


I have not seen that Sensor Shield before..

The three pins are +5, GND and Signal. Try touching the wire you show to each of the 3 pins and tell us results...

here are the results

in the following supposing that
pin above is +5,
middel pin is GND and
low pin is Signal
(see photo)

When I touch the 2 wires to +5 and GND then the LED blinks correct
When I touch GND and SIgnal then the LED blinks correctly as well
When I touch +5 and Signal then the LED glows permanently)

When I touch GND and SIgnal then the LED blinks correctly as well

That's RIGHT I believe. That's what you did in the Photo.

Seems like some connector or something is wired wrong?? Not all 3-pin cables and "sensor shields" have the same sequence :0

but if it is the wiring why then did it function before? I do not see what has changed in the wiring. Perhaps some intern software things was destroyed when I pulled off the USB cable?

Geko, you wired the led 'temporarily' for these tests, right??

Are you using a cable or plug onto the Sensor shield for the LED for a more permanent connection?? If so, THAT cable or connector maybe the difference. Trace all the wring carefully...

thanks for your reply. I connected the led the way you see in the photos. the little cables made sometomes a instable connection (disconnection by moving the cable in the pin ) but the last trials seemed not to be attached by this. I tried it with and without power supply.