Sensore acqua

Salve, ho da poco intrapreso un progetto in cui viene impiegato l’utilizzo del sensore acqua di tipo standard (quello rosso per intenderci). Quando non è immerso nell’acqua emette un valore pari a 500, mentre quando vene totalmente immerso questo valore sale fino a 700 circa. Il problema è che con il passare del tempo il valore torna lentamente da 700 fino al valore iniziale simulando così assenza di acqua.

È un processo normale? C’è modo di risolvere continuando ad usare questo tipo di sensore o sarebbe meglio usare un galleggiante? Grazie in anticipo!

Buongiorno, essendo il tuo primo post, nel rispetto del regolamento della sezione Italiana del forum (… punto 13, primo capoverso), ti chiedo cortesemente di presentarti IN QUESTO THREAD ([u]spiegando bene quali conoscenze hai di elettronica e di programmazione[/u] ... possibilmente [u]evitando[/u] di scrivere solo una riga di saluto) e di leggere con MOLTA attenzione il su citato REGOLAMENTO ... Grazie. :)

Guglielmo

Scusate, fatto :)

... se metti il link al sensore che stai usando (esempio dove lo hai comprato), capiamo meglio le caratteristiche ;)

Guglielmo

Il sensore è di questo tipo qui:

https://www.amazon.it/Tenflyer-sensore-livello-rilevamento-Profondit%C3%A0/dp/B00RAZ5ZUI/ref=sr_1_4?ie=UTF8&qid=1539772592&sr=8-4&keywords=arduino+sensore+acqua

Mmm … non sono affatto sicuro che quel sensore vada bene in “immersione” …
… di solito quelli si usano per rilevare pioggia o umidità nel terreno … ::slight_smile:

Le specifiche di funzionamneto danno chiaramente: “Umidità: 10%-90% (non condensante)”

Se hai la possibilità di usare un galleggiante è molto meglio :wink:

Guglielmo

Mi saprebbe indicare qualche tipo di galleggiante?

Magari se dai un po' più di dettagli ... tipo di serbatoio, dimensioni, ecc. ecc. ... non solo io, ma anche qualcun'altro può darti qualche idea ;)

Guglielmo