Sensore per stampante

Ciao a tutti, Sono riuscito a smembrare una stampante e vorrei utilizzarne i sensori. Ho preso questo sensore:

https://picasaweb.google.com/albertopostacchini/23Luglio201102?authuser=0&feat=directlink

ma vorrei sapere come funziona, qualcuno ha mai provato??

il mio progetto è quello di farci un banco di prova per tarare i robottini.

Ciao albyy911 Il Tuo album su Picasa non é pubblico; non possiamo vedere la foto che hai vuluto faci vedere. Ciao Uwe

uwefed: Ciao albyy911 Il Tuo album su Picasa non é pubblico; non possiamo vedere la foto che hai vuluto faci vedere. Ciao Uwe

Nella fretta nn l'ho impostato pubblico :(

Quello é un encoder incrementale. La ruota ha delle linee sottili (quel circolo grigio tutto esterno che vedi) e il sensore lo misura. Il sensore ha un led e 2 fototransistori. serve una resistenza per il led e 3 resistenza per i fototransistori. segui le piste e li troverai e vedrai anche come collegarli sul alimentazione. La posizione del sensore rispetto la ruota é un po critica visto che le linee da leggere sono soltili. Ciao Uwe

Ho trovato questo sensore, penso che questa volta sia un interrupt

Proverò a collegarlo :)

ecco la foto e ditemi se sbaglio:

https://picasaweb.google.com/albertopostacchini/24Luglio2011?authuser=0&feat=directlink

Quello sono 2 optocopler a forcella che vedono se tra le forcelle ci sia un oggetto o meno. Si usano pre rivelare la posizione o presenza di qualcosa.

Tutto puó generare un interrupt, dipende come lo sui e come lo colleghi. È comunque meglio in caso di contatti aggiungere un circuito che fa il debounce elettroniacamente.

Ciao Uwe

OOOOOK!!! ci sono riuscito!!

ho collegato il sensore ad arduino seguendo questo schema:

http://upload.kanakh.com/uploads/12950178032.jpg

adesso però ho un problema, Quando leggo i valori del sensore lasciando qualcosa in mezzo, il serial monitor mi da questo risultato:

0 0 0 0 0 0 23 36 18 7 0 0 0 0 0 0 0 0 0 0 17 32 19 0 0 0 0 ...

Sembra che rilevi l'oggetto ogni tot di tempo, quando invece è sempre nello stesso punto, comè possibile??

:)

Una sfera di cristallo per favore. Senza codice non so risponderti. Ciao Uwe

uwefed: Una sfera di cristallo per favore. Senza codice non so risponderti. Ciao Uwe

Grazie, della risposta :)

il codice che ho utilizzato è questo:

void setup() {
  Serial.begin(9600);
  pinMode(13, OUTPUT);
}

void loop() {
  digitalWrite(13, HIGH);
  int sensorValue = analogRead(A0);
  Serial.println(sensorValue);
  delay(100);
}

il sensore è il seguente:

https://picasaweb.google.com/albertopostacchini/25Luglio2011?authuser=0&feat=directlink

che poi sarebbe lo stesso sensore di prima,l'unica differenza è che mi si è rotta una resistenza e quindi ho dovuto staccarlo.

Cmq ho fatto diverse prove nei collegamenti e mi ridà sempre lo stesso errore riportato nei post precedenti.

PS: il pin 13 l'ho acceso per avere un'alimentazione in più perchè pensavo che dovevo alimentare anche il diodo, ma penso che sia una cavolata XD

Ditemi se vi serve altro Ciao

prova di scrivere al posto di: Serial.println(sensorValue); la funzione Serial.println(sensorValue,DEC);

Ciao Uwe