Serial can't talk to SIM7000E module

Hi,

I just received a SIM7000E Arduino NB-IoT/LTE/GPRS/GPS Expansion Shield and have it connected to Arduino with Telstra Sim in Australia. Connected via Arduino Usb to PC and 12V 2A power supply to UNO.

I have been running the DFRobot_SIM7000_ATtest Sketch and able to use most AT commands. I can see the device is connected to the CAT-M1 network both via AT commands and the online sim control center.

Overnight however I am unable to communicate with the device via serial both Arduino serial and Putty.

When resetting device I get “Turn on SIM7000…” in Serial window however then there seems to be no connection. In Putty you can’t even type command into window. Not sure if this has something to do with baud rate. I am using software serial on Uno with switch set to D7 and D8.

I am new to this and trying to debug it seems that it gets stuck at turnON() which is where baudrate changes are made in DFRobot_SIM7000 code as some added Serial.println(“text”); get to there but no further not even an else statement in turnON()

The Net Led on the shield blinks about 11 times fast then 4 times slow (suspect connected) then about 12 seconds with nothing (suspect disconnected) which the online sim monitoring seems to agree with. Yesterday when able to communicate over serial was maintaining constant connection to network.

This is the Sketch I have been using.

Is there a reset to factory as such method for this board?

Here is code

/*
  * File  : DFRobot_SIM7000_ATtest.ino
  * Power : SIM7000 needs 7-12V DC power supply
  * Brief : This example use the serial port to send AT command to control the SIM7000
  *         With initialization completed, we can enter AT command to SIM7000 directly
  *         Common AT commands : 
  *         AT+CPIN? : Check SIM card
  *         AT+CSQ   : Check signal quality
  *         AT+CGATT?: Check net attached state
  *         AT+CSTT  : Start net connect task
  *         AT+CIFSR : Get local IP
  *         Get the AT command table in Resource folder :SIM7000 Series_AT Command Manual_V1.01.pdf
  * Note  : If you use Mega please connect PIN8 PIN10 and set PIN_RX = 10
  *         The AT command must end with CRLF
  */
#include <DFRobot_SIM7000.h>
 
#define PIN_TX     7
#define PIN_RX     8
SoftwareSerial     mySerial(PIN_RX,PIN_TX);
DFRobot_SIM7000    sim7000;
 
void setup() {
    Serial.begin(115200);
    while(!Serial);
    sim7000.begin(mySerial);
    Serial.println("Turn ON SIM7000......");
    if(sim7000.turnON()){                             //Turn ON SIM7000
        Serial.println("Turn ON !");
    }
 
    Serial.println("Set baud rate......");
    while(1){
        if(sim7000.setBaudRate(19200)){               //Set SIM7000 baud rate from 115200 to 19200 reduce the baud rate to avoid distortion
            Serial.println("Set baud rate:19200");
            break;
        }else{
            Serial.println("Faile to set baud rate");
            delay(1000);
        }
    }
    mySerial.begin(19200);
    Serial.println("For example, if you type AT\\r\\n, OK\\r\\n will be responsed!");
    Serial.println("Enter your AT command :");
}
 
void loop() {
    mySerial.listen();
    while(mySerial.available()){
        Serial.write(mySerial.read());
    }
    mySerial.flush();
    while(Serial.available()){
        mySerial.write(Serial.read());
    }
}

Your thread title is completely wrong. You are NOT using Serial to talk to the SIM7000E.

You are using Serial to read from/write to the PC. You are using an instance of the SoftwareSerial class to talk to the SIM7000E.

What changed between the Arduino being able to talk to the SIM7000E and it not being able to?

@antc

Hi

I got a SIM7000E module and tried with Telstra and Vodafone SIMs in Australia, but it doesn't get connected to the network. They are regular SIMs issued for voice / data, works with mobile phones. Any idea why the connectivity issue with SIM7000E? I have powered the SIM7000E with USB.

Hi,

I've tried the same with a SIM7000C in Australia. No success. Does anybody know how to get it running in Australia?

I am in Melbourne Australia.
I am using DFRobot Simm 7000C shield, V1.
I have not been able to get any response back from the SIM7000C
ie. never been able to get a response, never seen an OK.

Can power it up network LED flashes at approx 1 second rate.
Press and hold Boot Switch and it goes to approx 3 second flash, so think it is connecting to the Network.
Tried both Optus and Telstra Sim cards.

Tried both Software Serial and Hardware.

Are other people having trouble getting the OK response, or is this an indication I have a dud shield.

Please comment if you have had success with this shield in Australia.

Having same problem, anyone have success or know of alternative for getting mobile data service to arduino project?

Hi im facing the same issue... My Sim7000 cant turn on suddenly. till morning working fine... why is that so ?

Tried using the boot button on the shield?, alternatively, you need to bring up pin 12 to high for 2 seconds to boot then back to low.it.

Hi all,

Anyone can help me for understanding pin connections of Arduino and SIM7100.

I know Arduino RX to TXD SIM7100 and TX to RXD and GPIO to RI.

But what about CTS, RTS, DTR, DCD where should be connected to Arduino?

Thanks

Hey please I'm facing the same problem tell me how did you fix it?