Serial Comms

I’m taking a stab at the attached PDF trying to go to arduino.
I’m not planning on using the line labelled L, and I’ve replaced the FT232BM with an arduino.

I’m using SoftwareSerial as it’s a non standard baud rate at 15625 baud, and I’ve added rough timing for that to the library.

I’ve tried connecting but I don’t get any data back - so I’ve taken the circuit connected the K line to a multimeter intending to see the line dip below 1V for 200ms x 7, however during that bit of the code, the line is around 8.35V.
When idle the line sits at 8.95V.

My thought is the RX line is holding it high how I have wired it - so I’ll describe it.

I have replaced SD601 with BC337, I’ve got the K line coming into the circuit and it’s held high with a 1K resistor. On that same line of the breadboard, I’ve got two jumpers one takes the signal to the transistor to be grounded, the other goes to the RX optocoupler.
I believe somewhere amongst this is what is holding it high (I can’t see what I’d call a logic 0 in my testing).

Any thoughts based on the schematic what might be a problem? I assume the schematic to be correct though I did look at the 1k to ground at the base of the transistor as well - changing it to be inline did nothing.

openport.pdf (24.4 KB)

see the line dip below 1V for 200ms x 7

Does your MM respond that fast? I'd forget the Arduino and tie TX high/low with a wire for testing.

Maybe Q1 is not turning on properly. How's it's gain compared to the SD601?

What about reducing R8?


Rob

tocpcs: I'm using SoftwareSerial as it's a non standard baud rate at 15625 baud, and I've added rough timing for that to the library.

HardwareSerial can handle that, I just tested it to make sure.

I found an issue in how I connected to the optocoupler that was holding it on when it should not have.

Now I have it switching on / off as it should on TX. RX I'm not so confident is working (I'm still not receiving a response as desired).

When I hold the K line low (direct short to ground) RX reads 1.10V. When I release it, RX reads 3.69V.

I've swapped the 330ohm resistor for a 510 ohm resistor, but that's giving me 2.59V and 0.5V.

I need that short to ground to read closer to 0 I think for the serial library to read it correctly (as a logical 1) - so why can't I get it to show 0V exactly using a 330ohm as the pull up to VCC?