Serial Monitor not working

Hi
I have a Leonardo and Arduino 1.0.5 on a Win XP laptop and it seems that my Serial Monitor is not working. I can upload without issues, but the Serial Monitor is dead.

I tried all I could think of: all datarates, code while(!Serial), all delaying until the Serial monitor starts ,etc. I suspect now the HW, but I hope it is not (as usual :stuck_out_tongue: ).

Basically, the Arduino doesn't transmit anything to the PC, no matter what code I sent and when I try to send something, I get this message:

///////////////////////////////////

java.io.IOException: Input/output error in writeArray
at gnu.io.RXTXPort.writeArray(Native Method)
at gnu.io.RXTXPort$SerialOutputStream.write(RXTXPort.java:1124)
at processing.app.Serial.write(Serial.java:517)
at processing.app.Serial.write(Serial.java:540)
at processing.app.SerialMonitor.send(SerialMonitor.java:200)
at processing.app.SerialMonitor.access$100(SerialMonitor.java:32)
at processing.app.SerialMonitor$3.actionPerformed(SerialMonitor.java:89)
at javax.swing.JTextField.fireActionPerformed(JTextField.java:492)
at javax.swing.JTextField.postActionEvent(JTextField.java:705)
at javax.swing.JTextField$NotifyAction.actionPerformed(JTextField.java:820)
at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1636)
at javax.swing.JComponent.processKeyBinding(JComponent.java:2851)
at javax.swing.JComponent.processKeyBindings(JComponent.java:2886)
at javax.swing.JComponent.processKeyEvent(JComponent.java:2814)
at java.awt.Component.processEvent(Component.java:6040)
at java.awt.Container.processEvent(Container.java:2041)
at java.awt.Component.dispatchEventImpl(Component.java:4630)
at java.awt.Container.dispatchEventImpl(Container.java:2099)
at java.awt.Component.dispatchEvent(Component.java:4460)
at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1848)
at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:704)
at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:969)
at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:841)
at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:668)
at java.awt.Component.dispatchEventImpl(Component.java:4502)
at java.awt.Container.dispatchEventImpl(Container.java:2099)
at java.awt.Window.dispatchEventImpl(Window.java:2475)
at java.awt.Component.dispatchEvent(Component.java:4460)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
/////////////////////////////////////////

Any suggestion will be appreciated.

Have you tried another serial app? HTERM is very good. Did the leds (rx/tx) in the arduino blink?

Yes, I tried this too, still no data...
When I connect, the Rx led blinks, but then nothing.

It sounds like the culprit is not the Serial Monitor :roll_eyes:

I don't know a lot the Leonardo, but it seems the serial communication is not in the same device, so it might be a problem that you are using another port. Maybe someone with more experience in this board can add something extra to allow you to troubleshoot the issue.

If you have a serial-usb board, you can try to link up directly the cables to the RX TX pins to discard any 'internal' issue.

I noticed that also the "Burn bootloader" doesn't work, I get this message:
avrdude: usbdev_open(): did not find any USB device "usb"

Arduino Leonardo is my Device list, under Ports(COM28). Should I have somewhere a "USB" device?

I have the same trouble here, IDE 1.0.5 and leonardo board.
I'm also struggling to work with the MIDI protocol on the UART serial port on digital pin 0 (rx) and digital pin 1(tx), that also seems to have problems.

I think is definitely a problem related to the serial management on the leonardo.

Strangely enough... I uninstalled Arduino, restarted, installed it back, restarted, plugged in Arduino Leonardo, installed again the drivers, restarted... and it works now...
All the best!