Serial monitor question

Can someone tell me why the monitor does not show anything. Thanks

#include <SoftwareSerial.h>

void setup()
{
Serial.begin(9600);
}

void loop()
{
Serial.println("Hello");
delay(50);
}

Assuming that you have opened the Serial monitor, what baud rate is it set to (bottom right) ?

Thanks, 9600

Why do you include SoftSerial when you don't use it?

Do you get errors when you upload?

Thanks. It's a faulty Arduino Nano. I just tried another and it works perfectly. Don't know why it died?

I included SoftSerial thinking it was needed. Thanks again for help.

But if serial printing fails because the Nano is broken, uploading must have failed as well...

I just tried loading blink. The leds's flash on the board during loading, but there is no blinking. So why is this happening? I do remember a short time ago, it got very hot on the regulator when I had 12v going into Vin. Can't think of anything else

But the upload does not fail?

And when testing, what powers the Arduino?

It gets powered by the USB lead during programming, however sometimes the supply to Vin is present. I have now reduced 12 volts to 9 volts on Vin.

I did read an article somewhere saying some of the Chinese copies of the Nano did not always switch over away from Vin when both were present. Maybe this caused a problem, don't know. All I know is the Nano got very hot with 12 volts going in on Vin and with the USB lead plugged in.

Ahh, so you're not testing with a single USB powered Nano then. Please test it again but this time nothing connected to it and USB powered :)

And last is bull, no need to "switch away". As long as GND's are connected it doesn't matter what powers it. And the selection of power source is pretty stupid simple, it's just a diode. :) So it gets its Vcc from Vin unless the output of the regulator is below 5V - Vdiode (aka, around 4,4V) and the diode from Vusb will conduct.

But both the regulator and the diode can't really supply much current and will break if you try to pull any current (like connecting relays, servo's etc). If you need to power that, use an external (switched mode) supply.

Thanks. I unplugged the Nano from my board, connected it via USB, tried to download. The Led's flash as though it's accepting the download, but it is still dead.

It had been working even though a couple of weeks ago got very hot. I never found out why it happened other than having USB and external 12v power on the board.

At least the Nano's are so cheap on Ebay, although hope its not the reason for failure.

Lights will flash no matter what. But what does the IDE tell you? It probably shows a failed upload...

You had nothing connected to the Nano at that moment other then 12V and USB when it got hot? And I really mean nothing, no leds, no relays, no motors, nothing.

And I never had one failed here except from my own stupidity (but even that they survive most of the time 0:-) )