Serial port and WiFi issues

I am having two strange things going on and not sure what topic this question belongs so forgive if this is not the right one.

Background. I am working on a project using a MEGA2560 and ESP8266. The MEG2560 collects temperature and heater status data and passes it to the ESP that has a web server running. Both were working fine last week.

Yesterday I went to work on the MEGA2560 and had trouble with the serial monitor out speed. The MEG2560 is set to 115200 but to get my computer to read the data it has to be set to 74880. Strange I thought but while I think about that issue went over to the ESP. I have it to scan WiFi and look for the strongest signal. I have two access points and want to use the strongest signal. Discovered the same baud rate issue and it could not find any signals. I know one is fairly strong where I am working on the project, actually picked up both most of the time. Thinking I may have damaged the wifi part got another ESP. Same issues. Tried another, same issues. Rebooted my computer. No change. I am at a lose. Could the two be related? What else can I do/check? Example WiFi code is below.

Thanks

/*
    This sketch demonstrates how to scan WiFi networks.
    The API is almost the same as with the WiFi Shield library,
    the most obvious difference being the different file you need to include:
*/
#include "ESP8266WiFi.h"

void setup() {
  Serial.begin(115200);

  // Set WiFi to station mode and disconnect from an AP if it was previously connected
  WiFi.mode(WIFI_STA);
  WiFi.disconnect();
  delay(100);

  Serial.println("Setup done");
}

void loop() {
  Serial.println("scan start");

  // WiFi.scanNetworks will return the number of networks found
  int n = WiFi.scanNetworks();
  Serial.println("scan done");
  if (n == 0) {
    Serial.println("no networks found");
  } else {
    Serial.print(n);
    Serial.println(" networks found");
    for (int i = 0; i < n; ++i) {
      // Print SSID and RSSI for each network found
      Serial.print(i + 1);
      Serial.print(": ");
      Serial.print(WiFi.SSID(i));
      Serial.print(" (");
      Serial.print(WiFi.RSSI(i));
      Serial.print(")");
      Serial.println((WiFi.encryptionType(i) == ENC_TYPE_NONE) ? " " : "*");
      delay(10);
    }
  }
  Serial.println("");

  // Wait a bit before scanning again
  delay(5000);
}

Not totally sure what was going on but, I tried it on another computer. Same. Switched the board from generic to NodeMCU 1.0 (ESP-12E). Worked, witch is strange because a couple months ago it did not. Switched back to generic. Still works. Must have been Grimlems

I don't use ESP based boards, but I think that 74880 is typical for ESP boards.

If I'm correct, it brings the question which serial port you're using on the Mega for communication with the ESP?