Serial port busy

I just got my Nano 33 IoT and I am currently trying to set it up. I am getting an error saying the port is busy. I have spent around 8 hours now trying to figure this out, and I can't think of anything else.

I am able to put it into bootloader mode, which allows me to program the board, but when it starts regularly, I get the exact same thing. I have also tried uploading bare minimum sketches and still get the same issue.

I have the SAMD boards installed and the correct one selected. I also have the correct COM port selected. I have even tried uninstalling the boards/drivers and reinstalling them.

I have checked the device manager to make sure there are no discrepancies there either. The board uses a unique COM port and uses the correct driver.

I have also disabled Bluetooth, as I have seen that it may cause issues.

I have even checked Process Explorer extensively to see if any processes are actively using it. The only time that anything resembling the board pops up is when I open the Serial Monitor when in bootloader mode.

I have rebooted my machine multiple times with no luck. One thing that I do notice, though, is that right when I reboot it, I am able to open the Serial Monitor successfully. However, if I try to upload a new sketch or reset the board, it goes back into saying the port is busy.

I cannot think of anything else, so a little bit of help would be greatly appreciated.

Could please be a bit more specific on your setup and where the message appears?

  • Which OS?
  • version of Arduino?
  • is this a pop up window or printed in the IDE output?
  • Exact message. Did you google the message. Sometimes you can find others had the exact same problem.

Do you have any other software that you use the Serial port with? Even if you do not have the COM port selected.