Serial port 'COM1' not found. Window 7 detected it in the beginning and stopped

I'm trying to install the drivers for the Arduino Uno on Windows 7 * For the first time arduino USB was plugged in, Window 7 detected the USB right away, but then after that, it stopped detecting it.

First step, I installed Arduino Enhanced Release 1.0.5 for Windows (installer, drivers, etc) +SRC http://forum.arduino.cc/index.php/topic,118440.0.html *Did not work for me, "Serial port 'COM1' not found"

Second step, I went to Device Manager -> Other devices -> Unknown device -> right click -> update drive software -> browse my computer for driver software -> Program Files (x86) -> Arduino -> Arduino ERW 1.0.5 -> drivers or Arduino ->drivers *Did not work for me either, "Window could not find driver software for your device."

Third step, downloaded Windows ZIP file, found ArduinoUno.inf http://arduino.cc/en/main/software I repeated the second step with ArduinoUno.inf *Did not work for me either, "Window could not find driver software for your device."

Fourth step, installed FTDI Drive, "FTDI Ready to use" *Did not work for me, "Serial port 'COM1' not found" is still shown on arduino

What else can i do to prevent this message, "Serial port 'COM1' not found."

*Tools>Serial Port is greyed out *File>Preference>idesettings_v104 , serial port=COM1 , debug_rate 9600

It's almost certain that your Arduino is not 'COM1' -- that's the first serial port, which will be on your motherboard.

Look in your control panel under "Printers and Devices" -- If you've got the drivers installed, it should show up there, along with the COM port that it is using.