serial port disabled in arduino ide on fedora 10

hi,

the serial port option is disabled in the tool menu of the arduino ide. except serial port everything is ok. how can i enable it. I m using fedora 10 OS.

thanks in adv...

I had this issue. For some reason the default settings in Fedora have the serial port disabled and you need to re enable it to use the arduino.

From what I remember you have to go in to
System -> Administration -> Users and Groups.

This should open the User Manager.
Select your user name and you should get the User Properties window open.

You need to then select the groups that will give you serial communication. These are UUCP and LOCK.

I'm running Fedora 11 and also enabled DIALOUT duno if this is relevant to 10.

:-[ Just noticed there is a playground page explaining Fedora setup :wink:
http://www.arduino.cc/playground/Linux/Fedora

i have selected both UUCP and LOCK but the serial port option is not enabled.

k thak you i got it. but i m getting these errors

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

Urmmm (I'm no expert you know :-/ )

Looks like the port is open now which is problem #1 solved. I'm not familiar with the new error.

I'm assuming you successfully ran through the set-up instruction in the playground?
http://www.arduino.cc/playground/Linux/Fedora

You selected the correct port in the Tools menu?
You selected the correct Arduinio board type in the Tools Menu?

I had some issues like this when I first installed Arduino in Fedora but usually tracked it down to a botched step in the setup.