Serial port greyed out on Arduino IDE, Windows 10

Hi guys,

I'm using a MKRZero with arduino software 1.8.5. PC is Windows 10, x64. I can't get my IDE to upload sketches (any sketch) to my computer. Exact error msg below :

Arduino: 1.8.5 (Windows 10), Board: "Arduino MKRZERO"

Sketch uses 23756 bytes (9%) of program storage space. Maximum is 262144 bytes.
PORTS {} / {} => {}
PORTS {} / {} => {}
...
PORTS {} / {} => {}
PORTS {} / {} => {}
Couldn't find a Board on the selected port. Check that you have the correct port selected.  If it is correct, try pressing the board's reset button after initiating the upload.

Funny thing is, the IDE says ArduinoMKRZero on COM5 at the bottom right corner of the screen, but the Tools/Ports menu is greyed out and I cannot select anything from it.

On the hardware side, I have tested several cables (including a brand new one), the board is visible from the device manager, and I get the vanilla W10 sound when I plug my board in.

The MKRZero is connected to a sensor in I2C , powers that sensor, and has an SD card in it, but none of that should interfere I believe.

The utlimate goal here is to use sevral sensors attached to the MKRZero with I2C and UART and to dialog with them using OOP so custom librairies for code maintenance issues. But as said before the upload doesn't work even with the Blink sketch.

There are several posts on the web with similar issues ; I have read some of them and tried in partiular uninstalling and reinstalling arduino IDE, I have updated the COM drivers of my PC with the ones in the Arduino package but still it doesn't seem to work.

I have read the troubleshooting guide and several similar posts on this forum but none of them solved my problem.

When I try the loop-back test (http://forum.arduino.cc/index.php?topic=73748.0) no sound comes out and Serial monitor doesn't see anything.

I will try to get it to work on another PC, but I would like to check that I haven't missed anything first.

Any ideas ?

Funny thing is, the IDE says ArduinoMKRZero on COM5 at the bottom right corner of the screen, but the Tools/Ports menu is greyed out and I cannot select anything from it.

What is shown on the IDE is the last board selected on the last port selected. Nothing about that information reflects current reality.

Use Device Manager (Control Panel + Hardware and Sound + Device Manager (under Devices and Printers) to see which COM ports are defined without the Arduino plugged in. Use it again with the Arduino plugged in. If there is a change, that is the port that the Arduino is connected to. If there is no change, you've f**ked your Arduino.

Thanks for the speedy response.

On the Device Manager there’s no Ports tab until the Arduino is plugged in, and I see a tab Ports (COM and LPT) with Arduino MKRZero (COM6) on it when it is plugged in.

So the Arduino lives. So far so good.

On restart my IDE tells me it finds an Arduino MKRZero on COM6, both in the ports tab on top and down below (the ports tab isn’t greyed out anymore). So it finds the board normally, but instead of loading the sketch it just says :

Forcing reset using 1200bps open/close on port COM6
PORTS {COM6, } / {COM6, } => {}
PORTS {COM6, } / {COM6, } => {}
...
PORTS {COM6, } / {COM6, } => {}
Uploading using selected port: COM6
C:\Users\X\AppData\Local\Arduino15\packages\arduino\tools\bossac\1.7.0/bossac.exe -i -d --port=COM6 -U true -i -e -w -v C:\Users\X\AppData\Local\Temp\arduino_build_630268/Main.ino.bin -R 
An error occurred while uploading the sketch

The resetting part is very long. After that the ports tab is still not greyed out but the same process is repeated if I try to upload again.

If I press the reset button on the board we’re back to step one ; serial port greyed out, “couldn’t find a Board on the selected port” error. Reuploading causes the same issue time and time again.

According to this :http://forum.arduino.cc/index.php?topic=432363.0 it’s a bootloader issue but I’m confused about how to solve it…