Serial Port greyed out.

I use an Arduino Mega for testing and that works fine.

I use Adafruit 5V Pro Trinkets for the actual evices I make and that has worked fine...up to now.

Suddenly, the serial port for a connected Pro Trinket is greyed out...on ALL my Pro Trinkets and I have about 20 of them. They worked yesterday. They do not work today.

I have reinstalled drivers and rebooted...all to no avail. Please, can anyone suggest a solution, this is driving me insane!

This is the error I'm getting.

avrdude: error: usbtiny_transmit:
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

avrdude: error: usbtiny_transmit:
avrdude: error: usbtiny_transmit:

I can see the USBtiny device in Devece Manager..under libsusb-wi21 devices
BUt there's no info on ports for it - either in Windows or even in a picture i can copy, and port in Arduion IDE is stil firmly and resolutely blank.

Can you try a different USB port?

Wondering if you blew up the one you were using.

.

USB cable count: 3
USB port count: 5
PC count: 2

None of 'em working at all with four different Pro Trinkets.

Until about an hour ago when I bit the bullet, reinstalled IDE and suddenly they work - the port is STILL greyed out...but they will communicate, so at least I can program them.

Odd.