Serial port in Linux (Fedora 12)

I have used Arduino Duemilanove succesfully with my own laptop. Today I have tried to use it with two other laptops which both run Fedora 12. Both have problems with the serial port selection (Tools -> Serial Port). Please help!

  1. MENU TOOLS -> SERIAL PORT IS GRAYED

On the first laptop I can't select the correct serial port because the menu Tools -> Serial Port is grayed. I can't program my Arduino, the TX and RX LEDs are not lit.

  1. /dev/ttyUSB2 IS MISSING FROM THE MENU

On the second laptop I have a USB 3G (UMTS) modem, which has created /dev/ttyUSB0 and /dev/ttyUSB1. When I plug in my Arduino, device /dev/ttyUSB2 gets created and /var/log/messages contains no errors. However, I can see that both gpsd (gpsd.hotplug) and NetworkManager try to probe /dev/ttyUSB2, but both fail. When I start the Arduino Java application, menu Tools -> Serial Port displays only /dev/ttyUSB0 and /dev/ttyS0 but not /dev/ttyUSB2. Permissions for files /dev/ttyUSB* are identical. There is only one lock file (/var/lock/LCK..ttyUSB0) for the 3G modem.

For both machines I have added myself to group dialout, uucp and lock. In addition to that I have issued command "newgrp dialout" before starting Arduino GUI. The files /dev/ttyUSB* have group dialout.

OK, now I know how to get this working! The trick is that you must first start the Arduino GUI and after that plug in the USB cable for Arduino! So the order matters here!

It works in Ubuntu in either order but it can take a good while (half a minute sometimes) for it to appear in the IDE. Maybe its the croaky old computers I run it on :wink: