Serial Port in Tools>Serial Port Greyed out. Help! 1.0.6

Let me start by saying i’m using 1.0.6 because I’m using a Hummingbird Duo, and it’s firmware and such wouldn’t work on any other version, even though it says 1.6.0 is supported. (I’m not really sure what happened, I just tried everything until I could click on verify and it worked. I’m running Linux (Arch, if that’s important) and I downloaded the IDE from the website, not with pacman.

I have installed the Arduino firmware on the device, and have installed the Hummingbird libraries, and board in Tools>Board

Running lsusb shows one device which I have determined is the Arduino:

Bus 004 Device 012: ID 2354:2222

Running dmesg (only pasting relevant lines) gets me:

[ 7721.948163] usb 4-2: new full-speed USB device number 14 using xhci_hcd
[ 7722.131272] usb 4-2: New USB device found, idVendor=2354, idProduct=2222, bcdDevice= 2.00
[ 7722.131285] usb 4-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 7722.131291] usb 4-2: Product: Hummingbird Duo
[ 7722.131298] usb 4-2: Manufacturer: BirdBrain Technologies
[ 7722.153871] hid-generic 0003:2354:2222.000D: hiddev2,hidraw4: USB HID v1.11 Device [BirdBrain Technologies Hummingbird Duo] on usb-0000:00:10.0-2/input0

So the device is connected, but running ls /dev/tty* gets me:

dev/tty    /dev/tty14  /dev/tty20  /dev/tty27  /dev/tty33  /dev/tty4   /dev/tty46  /dev/tty52  /dev/tty59  /dev/tty8
/dev/tty0   /dev/tty15  /dev/tty21  /dev/tty28  /dev/tty34  /dev/tty40  /dev/tty47  /dev/tty53  /dev/tty6   /dev/tty9
/dev/tty1   /dev/tty16  /dev/tty22  /dev/tty29  /dev/tty35  /dev/tty41  /dev/tty48  /dev/tty54  /dev/tty60  /dev/ttyS0
/dev/tty10  /dev/tty17  /dev/tty23  /dev/tty3   /dev/tty36  /dev/tty42  /dev/tty49  /dev/tty55  /dev/tty61  /dev/ttyS1
/dev/tty11  /dev/tty18  /dev/tty24  /dev/tty30  /dev/tty37  /dev/tty43  /dev/tty5   /dev/tty56  /dev/tty62  /dev/ttyS2
/dev/tty12  /dev/tty19  /dev/tty25  /dev/tty31  /dev/tty38  /dev/tty44  /dev/tty50  /dev/tty57  /dev/tty63  /dev/ttyS3
/dev/tty13  /dev/tty2   /dev/tty26  /dev/tty32  /dev/tty39  /dev/tty45  /dev/tty51  /dev/tty58  /dev/tty7

On 1.6.0 I got the port to show, and work, but the Hummingbird software wouldn’t work. I am using the same cable, so that is not a problem.

I apologize if that was too detailed but I wanted to get as many of the issues I already read out of the way as possible. I think the problem is the device isn’t showing up in tty as /dev/ttyUSB0.

EDIT
Interesting little fact, those smarter than me were probably able to figure this out from the above information, but the Arduino is listed as /dev/hidraw4. I tried to set that as the port in prefrences.txt but it did not work. I am going to try installing a different version of Arduino again and see if the firmware works by some magic. If it does I’ll edit again.