Serial Port Issue

I am using the arduino uno at school and have decided to buy my own for home use. I installed the arduino software (1.0.5) Then plugged in the arduino board into my front usb 2.0 slot. The drivers installed fine ( i believe, no errors were shown). I went to the arduino software and looked under, tools>serial-port, but serial-port is grayed out. Both the yellow and the green lights are solid on my board. But i cant do anything with it until i can select a serial port. Please help i do not know what is wrong! Thank you!

UPDATE: The arduino board is under other devices in the device manager, listed as "unknown device". I am still yet trying to install the drivers.

UPDATE: I found the drivers, but when i try to install it i get "A problem was encountered while attempting to add the driver to the store."

were you using window 8.1 pro platform?

I had the same problem, but when i look under device manager the USB for the arduino comes up as an unknown, when i go to updated it, it cant show the arduino so the update fails. Does anyone have any advice on how to fix that. :~

this got me a suspected about the modem USB.

have you tried the VCP Drivers - FTDI depends on your platform.


I tried the tutorial you gave but I got this (Windows encountered a problem installing the driver software for your device) then it also said (WIndows found driver software for your device but encountered an error while attempting to install it.) It also says (This device cannot start.(Code 10)).

Could you please help me out I been trying for a week.

I am having the same issue with my grandson's Arduino. In Device Manager, the Arduino is seen as "Unknown device". When I try to install/update drivers I get the Windows error window ( Problems encountered....). I also have tried all of the suggestions in this thread and in some others that I have found in the forum.

I have a Dell laptop with Windows 8/64bit....everything works fine on my computer. Can't figure out what is wrong on my grandson's.

Please help if you can....we are both very anxious to get him started on his Arduino.

Thanks in advance,


Sorry, I forgot to mention that my grandson's new tablet is a Windows 8/64 bit as well.



this should work for you guys. I had the same issue and followed these steps and it work just fine for me. I'm up and running now! :smiley: