Serial port not detected by Mac (High Sierra) with MKRZero


I'm trying to use my brand new MKRZero but my Mac is not recognizing the USB connection. I tried following the steps here to update my FTDI drivers but it hasn't worked. I've tried with multiple USB cables and on two Macs. I haven't tried windows/linux yet. When I originally got the board last week, I was able to connect and upload sketches but I can't anymore. Any ideas?

That was quite old information on the FTDI.

In you case it would not really help.
Have you tried quickly double tapping the RESET button to put it into BOOTLOADER mode ?
It should put it on a new COM port and allow you to upload.

I normally suggest sending the BLINK or BARE MINIMUM sketch to clear out the last sketch once you have it in bootloader mode.

Sending a new sketch should also put it back on its normal COM port once it has uploaded a new sketch.

Uploading in bootloader mode works sometimes. I can upload the blink sketch and it works. When I upload my own sketch, it does not work. Not even the builtin led. I tried burning the bootloader and got this:

Open On-Chip Debugger 0.9.0-g932ec70 (2017-02-15-12:33)
Licensed under GNU GPL v2
For bug reports, read
debug_level: 2
Info : only one transport option; autoselect 'swd'
adapter speed: 500 kHz
adapter_nsrst_delay: 100
cortex_m reset_config sysresetreq
Error: unable to find CMSIS-DAP device

Error while burning bootloader.

waveGen.ino (1.43 KB)

Timing of the double click can be a little tricky.

Unfortunately my coding skills are quite limited so you might want to ask about that aspect in the programming section.