Serial Port not populating under Tools Tab after FTDI drivers where installed

To whom it may concern.

I have a quick question. I currently have a Lilypad Simple and a FTDI Board. Under the processor, I have ATmega328 and under Board manager I have Lilypad Ardunio. I downloaded the drivers for the board at VCP Drivers - FTDI. After, I restarted everything. However, upon re-opening the arduino software to run the blink script. I found that the port tab is still grayed out. As a precaution I downloaded all .exe driver files and installed them. Unfortunately, this didn't work. I'm wondering if I did something wrong in the install. Or, if it could be the hardware

https://www.amazon.ca/Makerfire-Breakout-Arduino-Upload-MultiWii/dp/B00OIZLMEG (FTDI board)
LilyPad Arduino Simple Board - DEV-10274 - SparkFun Electronics (Lilypad Simple)

Thanks,

T

I'm assuming you're using Windows.

  • Unplug the USB from the FTDI board
  • Open Device Manager,
  • Plug the USB into the FTDI board
  • Do you see a new device appear? It should be under Ports (COM & LPT) or Other Devices.

Pert:

Yes I’m currently running window 10.
I tried what you said. Unfortunately, the port tab in the drop down menu is still grayed out. I went back to the official FTDI site and looked through the manual installation process. After re-downloading and re-plugging in the drivers and FTDI board. I found under Windows button/device manager/universal serial bus controller. The (usb serial converter) is not populating… I tried viewing hidden items to see if my computer hid it for some reason, but it wasn’t there. Below are some pictures of what I’m seeing

Thanks.

T

The instructions in my last post were not intended to get it working, the point was for you to give me information I could use to help you. Please answer the question:

pert:
Do you see a new device appear? It should be under Ports (COM & LPT) or Other Devices.

Pert:

Yes, It also changes when I change ports. Prolific USB-to-Serial Comm Port ← what is listed under >ports (COM & LPT)

Ok, the problem is that the Amazon seller scammed you. It's not an FTDI adapter, it's using a different brand of chip, Prolific. Probably it's the PL2303. I was wondering why the photo on that amazon listing had the top of the chip either sanded or photoshopped so you can't see the markings, I was guessing counterfeit FTDI. Well with those business practices it might still be a counterfeit PL2303 but hopefully not. The FTDI drivers won't work for the PL2303 and the Arduino IDE also doesn't include those drivers. You will need to install the driver. I have no experience with Prolific but try these drivers out: Products