'Serial port not selected' error message

After I enter my main code and click on 'upload', I get the error message that serial port not selected. In the Tools drop down, the Port tab is greyed out.
Also when I open the Device Manager, it says the drivers are not installed. I did download the drivers when I first downloaded the Arduino Desktop IDE software. But when I deleted the whole program to re-download the software to try again, it did not ask to install the drivers anymore.
I have the Nano board.

WHAT nano board? Is it a genuine Arduino product, or a clone?

It is a Arduino Nano Classic.

On the board yhere is the 328 chip, and another chip, can you tell us what markings the 2nd chip has please. Hopefully we can get you up and running!

   I don`t which one you need, so here are pics of the chips on the board.

BTW, I bought 3 of these Arduino Nano boards together as a kit. All of them will show the same error message of 'serial port not selected'.

The last image shows the CH340 chip. You need to install the driver for that. Download CH341Ser.zip from the Chinese manufacturer's website and install.

Alternative (possibly outdated) link on How to Install CH340 Drivers - learn.sparkfun.com

Downloading the CH340 driver fixed the port issue. The code can now be uploaded to the Nano.
Thank you.

I am re-opening this post. I did not realize the Nano board I have is not an official Arduino. It is a copy.
So, I bought a new Arduino Nano from this website.
Now, I am back to the same problem I described above. Under Tools> Port is greyed out again. Do I need to download the same driver again? Here are the numbers on the chips on the official Arduino board.

The FTDI driver should be installed when you install the IDE

What does Windows device manager think of your new board? Any new yellow triangles when you connect it?

What is the exact error when you try to upload. New original Nanos come with a different bootloader. Which options are shown in the IDE under tools -> processor? In newer IDEs, it should have 3 options:
328P
328P old bootloader
168P

For your new Nano, it's more than likely 328P.

In the Device Manager, it shows a flag under Other Devices; FT232R USB UART. It says drivers for this device are not installed. I tried clicking on Update Driver, but it does not find any drivers.

The error message that appears when I try to upload is:

Arduino: 1.8.15 (Windows 10), Board: "Arduino Nano, ATmega328P"

Sketch uses 1190 bytes (3%) of program storage space. Maximum is 30720 bytes.

Global variables use 13 bytes (0%) of dynamic memory, leaving 2035 bytes for local variables. Maximum is 2048 bytes.

An error occurred while uploading the sketch

avrdude: ser_open(): can't open device "\.\COM3": The system cannot find the file specified.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

I tried all 3 bootloaders... 328P, 328P Old Bootloader, and 168P. Under Tools> Port is always greyed out.

The directory should be C:\Program Files (x86)\Arduino\drivers\FTDI USB Drivers; but I always battle with this stuff :frowning:

If you don't have the driver installed, that is not the Arduino Nano; it's probably the other Nanos that you have.

As long as you don't have the option to select a port, that will have no effect.

I installed the drivers that were in FTDI USB Drivers. It was dpinst-amd64..exe It did not do any thing. Update... In the Device Manager, it changed the FT232R USB UART to a blue question mark???

Yes, that was from the other "fake" Nano board. I cant change the Com port. I dont know what else to do?

I have no idea, sorry.

The Arduino boards are worse than the copies. Both are worthless junk.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.