Serial port problems on Mac 10.7

We have the following setup: - MacMini mid 2007 with os 10.7.5 and Java 6 - Arduino Mega 2560

We have problems with the Arduino IDE as well as with Max/MSP accessing the Arduino.

In the IDE, under Tools > Serial Port, we only have Modem-Bluetooth and Modem-PDA. In System Information >: System Report > USB, the Arduino is listed as one of the available devices.

We tried changing cables and swapping ports, so far without success.

Does anyone have any suggestions what to try next to solve this?

Thanks in advance!

No one has similar problem???

OK I have tried to reinstall the firmware of usb chip, but have same result. I see arduino in system information, but there are no port available.

I tried with newer mac mini and I noticed strange behavior. When I print available ports in Max/MSP console some times arduino was found on port a, but some times it’s on c.

Any ideas?

Ok, I have install MocoLUFA firmware. Seems to be good. And it solves my problem. I am not sure, is it possible 16u2 firmware to be the problem?