Servo MG990 is not working in bidirection

I have brought a new SERVO MG990 and connected it to the arduino, all connections are perfect. After uploading program the clockwise rotation is perfect but during anticlockwise my servo is just slightly vibrates but no rotates. Please help me out its urgent. :confused: :confused:

Most likely a servo power problem.
You ofcourse don't power the servo from the Arduino 5volt pin,
because the (unspecified) Arduino is not a power supply.
Leo..

I've deleted your other cross post @suganp.

Cross posting is against the rules of the forum. The reason is that duplicate posts can waste the time of the people trying to help. Someone might spend 15 minutes writing a detailed answer on this thread, without knowing that someone else already did the same in the other thread.

Repeated cross posting will result in a suspension from the forum.

In the future, please take some time to pick the forum section that best suits the topic of your question and then only post once to that forum section. This is basic forum etiquette, as explained in the sticky "How to use this forum - please read." post you will find at the top of every forum section. It contains a lot of other useful information. Please read it.

Thanks in advance for your cooperation.

Bro, Then how to power the servo @Wawa

I'm new to forum, That was an mistake i don't know how to post after knowing how to use then i reposted this topic in right area. Hereafter i won't happen. :slight_smile: @pert

Thanks! If you ever need to have a topic moved to another forum section, you can click the "Report to moderator" link on the post and ask for us to move it.

Then how to power the servo

Use a 5-6V power supply capable of providing more than 1 Ampere (4xAA batteries, cell phone charger). Connect the positive power supply lead to the positive power terminal on the servo, and be sure to connect ALL the grounds.

jremington:
Use a 5-6V power supply capable of providing more than 1 Ampere (4xAA batteries, cell phone charger). Connect the positive power supply lead to the positive power terminal on the servo, and be sure to connect ALL the grounds.

Okay bro than you