Servo motori rotti?

Ciao a tutti, ho cercato di riutilizzare dopo un po' di tempo un lavoro che avevo fatto e ovviamente non ha funzionato. Avevo due linee di alimentazione a 5v e avevo usato 1 cavo colorato per il GND, un cavo colorato per il VCC e un cavo bianco striato per l 'altro VCC. Geniale da parte mia.

Ad ogni buon conto, ho collegato il GND su VCC. Questo (GND)VCC era collegato con Arduino Duemilanove, e con una coppia di servomotori.

Il resto del progetto sembra funzionare, quindi sembra che arduino sia salvo. Forse ha una protezione contro questo genere di scemenze... ? I servo motori che hanno avuto il loro cavo + collegato con 5v e il loro cavo - collegato con 5v vanno stranamente. Cioe' fanno un po' quello che vogliono.

Li ho sicuramente rotti? Posso debuggare la scheda di controllo (sono hitec)? Ho provato a caricare da un altro arduino il codice sweep (Servo) collegando il VCC dei motori al +5 di arduino, GND con GND e segnale sul pin9 (come da sketch). E' ok come prova?

Federico

Ciao,non credo si siano rotti i servo perchè se hai applicato sui due pin dell'alimentazione due +5v di fatto non gli hai applicato una ddp (differenza di potenziale).

Ho provato a caricare da un altro arduino il codice sweep (Servo) collegando il VCC dei motori al +5 di arduino, GND con GND e segnale sul pin9 (come da sketch). E' ok come prova?

Per la prova che vuoi fare va bene,se va a scatti potrebbe essere semplicemente un problema di alimentazione ,ovvero non hai abbastanza corrente per far funzionare il servo ed in questo caso ti conviene alimentarlo separatamente avendo cura di collegare insieme i due GND delle due alimentazioni. Ciao

Federico: Ad ogni buon conto, ho collegato il GND su VCC. Questo (GND)VCC era collegato con Arduino Duemilanove, e con una coppia di servomotori.

Se ho capito bene hai collegato sia il GND che il V+ del servo a 5V, se è così non hai rotto nulla, i problemi che lamenti nelle prove sono sicuramente legati al fatto che al servo non arriva abbastanza corrente, usa una idonea batteria (4-5 celle NiMh), o un alimentatore 5V in grado di fornire un paio di Ampere, per alimentare il servo e vedrai che tutto funziona come si deve.

Eppure eppure ... Sostanzialmente la mia applicazione ha 4 motori, di cui due funzionano, collegati a una linea di alimentazione, due vanno a caso. Invertendo le linee di alimentazione o utilizzando contemporaneamente la stessa non cambia. Collegando un altro arduino direttamente ai due motori che non vanno bene, continuano a non andare bene mentre quelli che vanno bene continuano ad andare bene.

Sto cercando di ricostruire cosa abbiamo fatto nel ricollegare... dunque... gnd era comune per entrambe le coppie di motori, e due vcc da 5volt da due alimentatori diversi. Ho collegato gnd su vcc, un vcc su gnd e un vcc era giusto. Quindi una coppia di motori ha ricevuto evidentemente vcc+vcc e sarà quella che funziona, mentre l'altra ha ricevuto vcc+gnd invertiti di polarità. E sarà quella che non funziona piu' bene....

Non è che non si muovano, quando li comando ogni tanto reagiscono, e poi si muovono da soli un po' a casaccio. Questa sera verifico tutto ancora e proverò ad aprirli ma dubito di poterli riparare in caso :-(

Federico: mentre l'altra ha ricevuto vcc+gnd invertiti di polarità. E sarà quella che non funziona piu' bene.... Non è che non si muovano, quando li comando ogni tanto reagiscono, e poi si muovono da soli un po' a casaccio.

Se hai collegato l'alimentazione invertita è possibile che hai danneggiato il ponte H che comanda il motore.

Stasera li apro per vedere che faccia hanno ste schede, anche se prevedo che non saranno riparabili dalle mie mani...

Si direbbero decisamente fumati... Questa sola scheda di controllo sarà reperibile ?

E si ,si è proprio bruciata :astonished:
Per i ricambi devi provare a rivolgerti a negozi di modellismo e vedere se ti possono dare la sola scheda e se conviene la spesa…

tonid: E si ,si è proprio bruciata :astonished: Per i ricambi devi provare a rivolgerti a negozi di modellismo e vedere se ti possono dare la sola scheda e se conviene la spesa..

Adesso vedo un po' come sistemare. Mi spiace che la foto sia cosi' un po' sfocata ma l'effetto a vista è notevole :-)

Federico: Questa sola scheda di controllo sarà reperibile ?

No, puoi solo acquistare un servo nuovo e tenere questo come ricambi per la meccanica.

Farò cosi. E starò più attento.

Federico: Si direbbero decisamente fumati... Questa sola scheda di controllo sarà reperibile ?

Il progetto http://www.openservo.com ha creato una scheda pilotaggio per Servo che viene pilotato in digitale via I2C. Costa intorno i 25€. Non so se é conveniente. I vantaggi sono che puoi pilotare anche la velocitá di spostamento e limitare la corrente che assorbe.

Ciao Uwe

scusate ma usando un normale ponte H non può convertire la meccanica rimanente del servo in un motore DC?

lesto: scusate ma usando un normale ponte H non può convertire la meccanica rimanente del servo in un motore DC?

Si, infatti esistono delle apposite schedine con sopra un ponte H da 1A che si montano dentro al servo al posto della sua elettronica trasformandolo in un motoriduttore a tutti gli effetti, ovvio che serve anche la relativa modifica alla meccanica per consentire la rotazione continua.