Servomotore con mosfet

Ciao a tutti, sto facendo il mio primo circuito alimentato a batteria e sto cercando di ottimizzare un pò i consumi. A dire il vero il componente che mi preoccupa un pò di più è un servomotore e ho deciso quindi di servirmi di un mosfet usandolo come interruttore per alimentarlo solo quando è necessario. Allego un'immagine del mio setup fatto con fritzing, giusto per rendere meglio l'idea: Ho volutamente omesso sensori vari e i condensatori sul regolatore di tensione per non confondere troppo il disegno, ho lasciato soltanto la parte relativa al controllo del servomotore. Sul mosfet ho messo un diodo come si vede in molti schemi, occorre metterne un altro subito dopo tra regolatore di tensione e servo come si fa per i carichi induttivi tipo relè e motori dc? Per ora il setup funziona così com'è, il mosfet ed il regolatore di tensione sono sempre freddi ed il circuito mi consuma sui 60mA, chiedo giusto per avere una conferma. Visto che non sono una cima se notate qualcosa di sbagliato nell'insieme, non vergognatevi di scrivere... :) Saluti per tutti

ciao Pelletta
La Tua soluzione non mi piace. (non é niente di personale)
Non mi piace mettere a massa con un transistore lo stabilizzatore.
Vedo meglio la soluzione adattata da Arduino nel comutare da alimentazione USB a alimentatore usano un transistore ndt2955 per “accendere” l’ alimentazione. http://arduino.cc/en/uploads/Main/arduino-duemilanove-schematic.pdf
ciao Uwe

La Tua soluzione non mi piace. (non é niente di personale)

Non preoccuparti, anzi sono felice che ci si possa confrontare, in fondo il forum serve a questo. Le critiche sono sempre ben accette e servono per migliorare, soprattutto per me che sto imparando. Ho fatto bene allora a postare tutto il circuito anzichè chiedere soltanto del diodo; giusto per curiosità e soprattutto per capire, come mai questo metodo non va bene anche se effettivamente funziona? Può compromettere in qualche modo la vita di qualche componente?