Seven Segment Display How to connect it to the breadboard and the arduino

please I need help on my Seven Segment Display, How to connect it to the breadboard and the arduino. when I see videos and connect exact way, it still does not work. any help please?

I couldn't get my RTC working today, can you tell me what the problem is?

You can't can you? And neither can we without information.

Post the details of the exact display you are using and the schematic you have tried.

Your first mistake might be that you are using videos to learn from. These tend to gloss over some details... and some creators think that "watching" someone silently go through steps is "teaching"

It is quite possible that it does not work when wired exactly like the video because you have the opposite polarity 7-Segment LED.

Some are common cathode... meaning that the segment pins get driven HIGH to light while some are common anode meaning that segment pins get driven LOW to light.

So you need to know which LED type you have.

Until we have details... we really can not provide much help.

Some are common cathode… meaning that the segment pins get driven HIGH to light while some are common anode meaning that segment pins get driven LOW to light.

That’s where you need to start but that being said , the displays should have a part number. I don’t know why you haven’t posted it. We can’t see the display so how are we supposed to help you ?

Hi,
Welcome to the forum.

Please read the first post in any forum entitled how to use this forum.
http://forum.arduino.cc/index.php/topic,148850.0.html then look down to item #7 about how to post your code.
It will be formatted in a scrolling window that makes it easier to read.

Can you please post a picture of your project?

Can you please post a copy of your circuit, in CAD or a picture of a hand drawn circuit in jpg, png?

Can you post links to spec/data of your displays?

What model arduino are you using?

Thanks... Tom..... :slight_smile: