Severe IDE bug with 0017 and 0018 on Ubuntu

In Ubuntu 9.04 I had a intermittant bug where the arduino window would stop accepting all keyboard input. Mouse buttons still worked, so I would have to save using the save button, then restart Arduino. This happened nearly every time I alt-tabbed.

Since upgrading to 9.10 now this happens any time I move, resize, or maximize the arduino window. It stops accepting all keyboard input. It is not hung though and still accepts mouse input. I tried installing 0018 and it's no different.

This is a crippling bug. Is there anything I can do?

I installed KDE and tried from within KDE an behavior is the same.

Hi, which java runtime are you using? There is nothimg really in the arduino-code that could expalin this behaviour. So I guess the JavaRuntime is causing the trouble. Could you post the output of this console-command

update-alternatives --display java


I use Ubuntu (8.10, 9.04 and 9.10) with Arduino 0017 and 0018, never had a keyboard issue at all. I'm with Wayoda, all the issues I have had have been with Java. In synaptic package manager, remove all the Java runtime stuff and install just the latest Sun JRE and its dependancies / plugins. The default open source stuff often conflicts with it in my experience.

[code] chaz@singularity:~$ update-alternatives --display java java - auto mode link currently points to /usr/lib/jvm/java-6-sun/jre/bin/java /usr/lib/jvm/java-6-sun/jre/bin/java - priority 63 slave java.1.gz: /usr/lib/jvm/java-6-sun/jre/man/man1/java.1.gz Current `best' version is /usr/lib/jvm/java-6-sun/jre/bin/java. chaz@singularity:~$ [/code]

Thanks for the info. If it's java, there's no point in my trying other solutions like trying another window manager. Arduino is the only thing I've had trouble with except pidgin. But it might be java since arduino is java. I will try the reinstalling thing. I just upgraded to 9.10 and installed sun-java-bin to get arduino working. I can't imagine it's not the most current.

I tried going into synaptic and reinstalling all the java stuff and it still does it. Any time I move the window or switch to a different window it stops accepting all keyboard info until I restart it. I have tried coding with a text editor and trying to compile the code without the Arduino program but the makefile was completely hopeless and I never got it to work. I literally can't finish the projects I'm working on at this rate.

In case anyone else has this problem, it was caused by scim. By killing scim the problem went away. Of course I haven't figured out how to type Japanese without scim, but at least I can type English now!

Hi, just in case I see that problem again: - You are running a japanese version of Ubuntu and scim does not work with the Arduino-IDE. - You have to kill/disable scim and then you are able to code in english

When I downloaded the JRE from Sun I think there has always been a special japanese version of the JRE. Is there one on Ubuntu?

I can't read this maybe it provides a hint for you?


I am not running a Japanese version of Ubuntu. I installed the normal english version, but I added Japanese language support via the gui tools. I never actually got it to work because they switched from scim to ibus for Karmic and it did not work for me out-of-the-box. In the process of trying to get japanese input to work, I installed scim. It is scim that was causing the bug. I could run "pkill scim" and the problem would instantly go away. I have since given up on Japanese input on that machine, since I don't usually need it.


I had the same problem that keyboard seems frozen.

I think the issue is more related to “Processing”. I installed “Processing” and did some coding there. I found the same keyboard frozen issue. That’s why it should be “Processing”, and Arduino has inherited the same bug.

I also tried to use Sun Java instead, but the problem didn’t go away.

I use another trick by opening an extra “dummy” sketch, by clicking File>New. This sketch is just a blank sketch and you need not code anything in it. So you have 2 open sketches on your windows desktop.

Something like this:

When you find your keyboard not responding, you can use your mouse to jump to “dummy” sketch first. And if you find your keyboard is alive again, you jump back ( using your mouse) to your working sketch

In my case, I can still leave scim running.