Shaky Ethernet connection(?)

Hello, I am noticing that at random, I cannot access my server in the barn and it cannot email to me. When this happens, It will succeed to email after many (>255) retries, 30" appart and I will succeed to access If I am lucky. This is quite new as during ~a year the connection went flawlessly.

Attache the wiring diagram.

I tried to to connect the b2h and c2h cables through a switch and everything seems to be working perfectly though I didn't test it over a long tome yet.

My question: is there a specification for the maximum number of rg45 connectors? and also, given my physical connection is completely static, is there a better way to connect the cables so as to have less loss or better quality signal? I have noticed that the wires canot be soldered(!)

Thanks for bothering

2021-09-20 13_25_42-Ethernet - Google Docs

What you need to check is the maximum cable length and cable type. two ethernet cables. Your drawing (nice) shows the cable lengths and the connectors. There is degradation with both cable and connectors. Is the cable to the barn exposed to weather and is it rated for that exposure. If not I would expect that to be your problem. You can get a 50 meter cable for not to much and just lay it on the ground and test it. If it works you found your problem. Are your connectors Gold, if not you may have oxidized contacts, wiggling them may cause your system to start working. If you have a cable tester you can feel better if they check. You did not state the speed or wire you are using, telling that might help.

Not necessarily, but each connection you make introduces opportunities for crosstalk. However, in my experience, connection issues like you describe are usually not caused by too many connectors on the line (within reason; you're pushing the limits I have to admit).
Probable causes are:

  • Dodgy crimped connectors on patch cables. Re-crimp connectors, especially ones you did yourself.
  • Broken cable; with this many conductors in a cable and a potentially hostile environment (going by the term 'barn' here...) it's not uncommon to have a bad patch in a cable somewhere.

You're probably using copper-clad aluminum (CCA) cable. If you want to solder, use pure copper core (solid or wire, choice is yours). Solders just fine, I can tell you. CCA probably not; never tried and I wouldn't bother to be honest. Try soldering something onto tin foil.

Anyway, perhaps a bit of an obvious question - have you ascertained beyond any doubt that it's the network infrastructure that causes the problem? I notice an 'Ino shield', suggesting you may be using self-written software - no change of a little bug creeping into that?

@ gilshultz, @koraks Thanks!

The cable and connectors are all protected from atmosphere nuisance.

I cannor replace the cable. It is in a sleeve, in a PVC pipe in a ditch

I think that the software is trusted. The same server, email and other internet related code are common to the barn ino and the home ino and the home one continues to work perfectly while the barn one does not respond

Today I realise that despite the bridge in the ext cabinet, barn ino does not connect. It did send the 09:02 daily report mail though but won't respond anymore. I am not at home right now and cannot tell if it died for any reason. Will know tomorrow.

What I think I need to do

1- With my lap in the barn run a batch with wget and monitor the error rates with a tbd windows tool

2- If there's a mean to sample the ethernet errors on the wisenet, to log them in my ino eeprom logger, learn what worsens the figures, figure up conclusions

3- find a mini screw (terminal) connector instead of the RG connector in the D4 wall socket: more compact and more reliable

Thanks again

Yes, those sound like sensible steps; particularly 1 & 2. I'd withhold the screwdriver part until it's clear what the cause might be - at least that's what I always like to do.

Just for good measure I'd also consider hooking up a known-good device to the barn ethernet connection (perhaps an old laptop or pc) and have it send pings or whatever over the line every second or so and log any errors. That may be easier/quicker to generate useful data and you're excluding the factor of a potential problem with that particular INO.

If you have a laptop you could put in the barn for a while, I would install Wireshark on the laptop and see whether that shows you any errors and what sort of errors. If you do see errors then try connecting the laptop to the ext cabinet and see if you get errors from there to your DSL router, if so move further along trying to identify the faulty segment.

Poorly terminated IDC connections in cabinets and wall plates sometimes only show up after a prolonged period especially if temperatures change. Worth checking the IDC connections in these locations if a cable that uses them shows up as suspicious.

Ethernet Interfaces can sometimes fail with varying symptoms, so if all the cabling checks out fine, then try a different port on your DSL router and a different Ino shield just to be sure.

As others have said, if you have any CCA cable be very cautious, it is often much cheaper than proper copper cable but also more prone to error. The aluminium in CCA can also corrode more easily especially where the copper coating is damaged (IDC connectors, screws etc.), this is more likely if the atmosphere is damp or colder.

Is there anywhere wildlife could attack the cable, mice like to chew the insulation which can cause an opening for other problems. Wasps can also damage the insulation , though I have not seen that go through to the metal cores yet.

I have used ethernet at 1GHz made up of about six patch cables (CAT5 - each 1 or 2m long) joined together plus patch cable from repeater to cabinet and cabinet to wall plate (cat 6) without problems, the total length being around 30m - none of it was CCA. I would not expect your cable length to be an issue, especially if it worked fine for 12 months.



Hello,
The cable is marked "tel ftp 4x2xawg24 cat-5e pvc iso 11801 eia/tia/568"

  • upper core picture is that of the cable with extremity scratched with a cutter
  • lower one is that of the core of a phone cable equally scratched. This can be perfectly soldered

It is evident the the enet core is not made from cupper!!

Back to my issue:
The experiment of adding a switch in ext cabinet leads to one conclusion: there is not continuous electrical failure. The failure is discontinued here. If it were continuous such as a marginal level or phase going occasionally below some threshold than the insertion of the switch, very probably, should have resulted in total success or total failure. This is not the case.

My conclusion, is that my issue must be mechanically continuous and electrically discontinuous: something like an open (or a short) as a result of temperature change. I tend to adopt @countrypaul idea of a failure at the cca idc i/f and will investigate this lane.

Thanks to all participants

@countrypaul - It's shamfull but truth predominate. While applying you suggestion to swap router's ports I found that the male from barn ino was misplugged :confused: I also realize that it could have been better to turn the router so that the ports (and antennas) face downwards to minimal dust deposit in the female RJ. Not sure if this is also convenient for the heat dissipation.

Issue still here! Same thing ever. It works normally some time and then it communicates no more, then it does again etc etc. Often, playing with a connector kicks it back to work.

It could be the termination of the cable is less than perfect, or even a dry joint in the router (changing port should eliminate that) or dirt on the contacts, or tired pins on the female side not spring hard enough to ensure a good connection.

If you have a spare switch put that between the router and the cable and when the problem appears (if it does!) try and work out whether it is at the router or the cable. If you have an RJ45 coupler that would do rather than a switch but in either case try and fasten the unit firmly so that moving a cable does not move the unit.

Yesterday, failing to access the barn server (home one ok) i unplugged replugged the router connection: nada. Went to the barn's 30m female end, tested - failure. Unplugged replugged the short jumper who's other end goes to the shield - working. Cutting 2 cm from the 30m cable, installing brand new, tool free rj female. Plugging the jumper - all is ok. Making several test using lan an Inet pathes - all is perfect. One hour later no connection. This morning (israel) working. 0902, getting daily report mail from both inos. 1100 till now 1450 no connection. Home always connect. Will continue the investigation including your recommendations when back home Sunday

@ countrypaul
I left my lap in the barn, from 20:00 yesterday to 09:00 today, pinging to the router using the cable disconnected from ino wirshark in parallel with ping running in batch loop every 10 secs. After. Imported the out.txt file to gsheets: 5115 times 0 packet loss(!) I am not sure what should I see on wireshark as broken enet frames are discarded at the nic(?) Any Idea? I may also try to wget big files from my phone but again, how would I know how did it went? counting specific tcp retransmits on this specific path? doesn't sound that simple. There's netstat -e but again, if the nic drops broken frames ??

Would you have expected to see any problems in that test period? If the wire was not faulty then you would not see any errors (lets look on the positive side!). What did you use to connect your laptop to the wire that runs from the barn? Was it direct? Using a patch cable (if so was this the same one as used with the server?)

Would it be feasible to swap the Ethernet shield in the barn server? If there was a problem with the Ethernet shield, such as a dry joint on the ethernet connector it might be impossible to track down without eliminating the hardware elements one by one and re-testing.

What Ethernet NIC does your laptop have? Which OS are you running on the Laptop? Most Ethernet interfaces can log errors in some way, and it should be possible to see how many errors have occurred on the card since it was last reset.

If using windows, I believe that setting SYSTEM\CurrentControlSet\Control\Network\Connections\StatMon\ShowLanErrors to 1 in the registry will give you more information - but have never tried.

In windows 10 you can use this command in powershell:

Get-NetAdapterStatistics | Format-List -Property "*"

countrypaul
Thank you!

During the night I ran a batch on the pc, at home, with wget in a loop, accessing every 10" the ino's server in the barn. There has been issues I need to analyze, using wget log. A bit sick - Will do it later. Barn's ino also reported two watchdog restarts at 23:29 and 00:43, both in the server function, cannot tell exactly where in the function but very probably in one of the call to wiznet: server.available(); client.connect() and client.available().

More details later