shield duplication unkown component

Hi

I need some help I recently purchased this module

https://uk.rs-online.com/web/p/networking-modules/1775516/

However now I want to add it to a personal circuit board which I am designing. I found a shield which i assume i can duplicate and wire the same way as the one I have, minus the sd card

http://wiki.seeedstudio.com/Seeeduino_Ethernet/

i downloaded the schematic and the eagle files, the problem I am having is identifying a component.
image 1.png which I have attached is the component and image 2.png gives me the information on it.

I felt as if it was a logic level shifter however now I’m not so sure.

is it any of these:

https://uk.rs-online.com/web/p/voltage-translators/1867235/

https://uk.rs-online.com/web/p/bus-transceivers/1661944/

If it is one of those can you let me know? However if it is either can someone help me determine which one it is

also can i program it the same way as the one I have, using pins 13,12,11,10, or would I need to program it via UART first which I highly doubt

Thank you

2.png

Hi,
Yes it is a 74ACT245, the difference is the package that it comes in.
TSSOP or 20-Pin SOIC.

Tom... :slight_smile:

TomGeorge:
Hi,
Yes it is a 74ACT245, the difference is the package that it comes in.
TSSOP or 20-Pin SOIC.

Tom... :slight_smile:

Hi Tom

Thanks for the reply just wanted to double check it is a voltage translator and not a bus transceiver

Hi

I’m trying to duplicate a shield however I’m having issues where it isn’t working, I’m trying to narrow down why. I have the pcbs already developed, it’s just I can’t seem to find out what I have done wrong. I have looked at the schematic for the seeeduino ethernet shield Seeeduino Ethernet over and over again, using that to check the tracks in mine, still no luck.

i have posted a question about this is the hardware section of the forum, however no luck so I’m going through each part of my pcb to help sort this out.

one component for the seeeduino Ethernet shield is a bus transceiver, on the schematic it says that component is 74ACT245 so i purchased this 74ACT245

However i was wondering if this is wrong and that the component should be 74HC245

am i correct in thinking i got it wrong by using 74ACT245

Thank you for all the help

Hi,

vj0104:
Hi
I’m trying to duplicate a shield

Why?
What do you mean doesn't work?
Does the 328 need a bootloader uploaded to it?
Can you post a schematic?
Thanks.. Tom.. :slight_smile:

I've merged your other cross-post @vj0104.

Cross-posting is against the rules of the forum. The reason is that duplicate posts can waste the time of the people trying to help. Someone might spend 15 minutes (or more) writing a detailed answer on this topic, without knowing that someone else already did the same in the other topic.

Repeated cross-posting will result in a suspension from the forum.

In the future, please take some time to pick the forum board that best suits the topic of your question and then only post once to that forum board. This is basic forum etiquette, as explained in the sticky "How to use this forum - please read." post you will find at the top of every forum board. It contains a lot of other useful information. Please read it.

Thanks in advance for your cooperation.

pert:
I've merged your other cross-post @vj0104.

Cross-posting is against the rules of the forum. The reason is that duplicate posts can waste the time of the people trying to help. Someone might spend 15 minutes (or more) writing a detailed answer on this topic, without knowing that someone else already did the same in the other topic.

Repeated cross-posting will result in a suspension from the forum.

In the future, please take some time to pick the forum board that best suits the topic of your question and then only post once to that forum board. This is basic forum etiquette, as explained in the sticky "How to use this forum - please read." post you will find at the top of every forum board. It contains a lot of other useful information. Please read it.

Thanks in advance for your cooperation.

Hi thank you for merging the two, f course will take it into consideration for next time. thank you again

TomGeorge:
Hi,Why?
What do you mean doesn't work?
Does the 328 need a bootloader uploaded to it?
Can you post a schematic?
Thanks.. Tom.. :slight_smile:

Hi Tom

Thank you for getting back to me, the other post has merged with this.

this post holds both my schematic and eagle file. of course if you need any other information i will be happy to provide it, thank you again for trying to help me, literally about to give up on this project.

Hardware Post

when i connect my pcb to an ethernet port i try to ping it (already changing my computers ethernet port to a static ip address that matches the one i have programmed my microcontroller with). i get destination unreachable over and over when i send a tcp packet to my pcb it suddenly changes to request timeout then back to destination unreachable, it is as if it picks up the command but nothing happens.

i have uploaded the bootloader (gammon). of course i upload a simple blink sketch and it works perfectly so im not sure what i am doing wrong.

i have attached this to my miso, mosi... etc on my pcb board and it works fine

WIZ811MJ

Thank you again

Hi,
Can you post your schematic and PCB pattern as jpg EXPORT files.
At the moment you assume we all have Eagle.

Tom... :slight_smile:

TomGeorge:
At the moment you assume we all have Eagle.

And we most certainly do not all! :astonished:

TomGeorge:
Hi,
Can you post your schematic and PCB pattern as jpg EXPORT files.
At the moment you assume we all have Eagle.

Tom… :slight_smile:

Hi Tom

Thanks for getting back to me. sorry i guess i just assumed that,
well as you asked i have attached the image of the board and schematic.
im hoping this is ok, and thanks again

power_module.zip (196 KB)

No, we don't do zip files either. They are a security risk. :roll_eyes:

TomGeorge:
Can you post your schematic and PCB pattern as jpg EXPORT files.

Paul__B:
No, we don’t do zip files either. They are a security risk. :roll_eyes:

Hi

Oh sorry i will remeber that for next time. again thank you

i will attach it to this menu.

i was curious is there a specific bootloader i have to load to work with the 5100

Thank you

power_module_brd.png

power_module_sch.png

Hi

Well i want to say thanks for all the help, i solved the issue and just incase anyone else comes along with this issue which i highly doubt, i solved it by replacing the 74ACT245 with a 74HC245

Thank you