Shield motor r3

Bonjour a tous
Je me suis offert la petite carte shield motor r3 pour piloter un moteur pas a pas bipolaire 12v,300ma par phase, et débutant je me pose plusieurs questions.

  1. j,ai lu qu'il était préférable d'alimenter le moteur par le Bornier a vis du shield moteur pour avoir une alim séparée moteur/commande, chose que j'ai faite en prenant soin de plier légèrement les pins vin et Gnd pour que lors de l'insertion de ce shield dans ma carte uno ces pins ne soient pas alimentées.
    J''alimente ma carte uno par USB et la shield par un transfo 12v 300ma.
    Voilà jusque la je pense être dans le bon
    Je connecte mon pas a pas sur les 2 canaux, et maintenant je pense être opérationnel pour la partie programmation

2)auriez vous un programme simple à copier coller afin de me familiariser à la commande de mon moteur, car les programme d exemple ne fonctionnent pas avec ma carte

Merci de m'aider, car je ne sais absolument plus quoi faire maintenant
Bonne journée
Olivier

Salut

La pin GND à remettre, sinon cela ne marchera pas !!!

A+

Bonjour Chabot, non j.ai fini par trouver un code et cela fonctionne malgré la masse non raccordée, je n ai désactivée que celle à côté de vin, pas celle à côté du +5v
Merci de m avoir repondu, c.est très sympa

Bonjour Docnet,
J'ai un soucis moi je veut déjà comprendre pourquoi je dois annuler les pattes d'alimentation sur le shiel motor R3 en cas d'alimentation externe. de plus est-ce les deux alim (3.3 et 5v) ? car à mon avis chacunes d'elles à son GND corespondant.

Et un autre soucis de compréhension est: pourrais-je toujours utiliser les ports là pour d'autres fonctions dans le même prgramme ?

Docnet:
en prenant soin de plier légèrement les pins vin et Gnd pour que lors de l'insertion de ce shield dans ma carte uno ces pins ne soient pas alimentées.

En principe ce n'est pas utile de les plier.
Il y a un jumper à déplacer sur la carte.

Docnet:
les programme d exemple ne fonctionnent pas avec ma carte

C'est bien un shield L293D que tu utilises ?

[/quote]

En principe ce n'est pas utile de les plier.
Il y a un jumper à déplacer sur la carte.

Bonjoir @Christian_R
tu parles de quel jumper ? pourrais-tu faire une capture d'écran pour nous autres? merci d'avance


c'est le jumper noir parqué PWR, à retirer si ce n'est pas l'arduino qui alimente le shield