Shield w5100 no found (Coll)

Buenas, resulta que estoy intentando conectar mi Arduino a la red con una placa de ethernet, w5100, el caso es que conecto el cable rj45 y no e encienden los típicos leds que entiendo que se deberían de encender, solo parpadea el led de “Coll”. He probado todos los ejemplos básicos que vienen con Arduino y algunos mas que encontré en la red, pero nada sigue poniendo lo mismo. El cable no puede ser que falle ya que si lo conecto a un portátil este tiene acceso normal a la red sin ningún tipo de problema.
¿Alguien tiene alguna idea de a que se debe el error?

Hi, it turns out that I am trying to connect my Arduino to the network with an ethernet board, w5100, the fact is that I connect the rj45 cable and the typical LEDs do not light up, which I understand should be turned on, only the “Coll” led blinks ”. I have tried all the basic examples that come with Arduino and some more that I found on the net, but nothing keeps saying the same. The cable cannot be that it fails since if I connect it to a laptop it has normal access to the network without any problem.
Does anyone have any idea what the error is due to?

What Arduino are you using and which W5100 board (post a link)?

Geekcreit
Geekcreit® uno r3 atmega328p development board no cable geekcreit for arduino - products that work with official arduino boards Sale - Banggood.com like this one

I meant a link to the Ethernet board as there are several different ones based on the w5100.

O sorry, yes its HanRun HR911105A 16/02

A good WS5100 board has a female 6 pin ICSP connector on the bottom. If you use a cheap clone UNO sans ICSP header, you won’t get very far.
Easiest to check is the Ethernet->UDP NTP client script, it will grab the time from internet.
Don’t forget to uncomment the second line below:

  •  // You can use Ethernet.init(pin) to configure the CS pin*
    
  •  //Ethernet.init(10);  // Most Arduino shields*
    

Why doesn’t the code-formatting work (only with dots in front it works)?

I already tried with several variations of the Ethernet.init (pin) command but nothing only turns on the coll led.
Maybe the board is broken?

HanRun is the name on the ethernet socket (where you connect your cable) and not the name of your Ethernet module or shield. So you have to find the name of the shield or/and a description or link to your supplyer. After that we can determine which pins you need for connection, and which library will match the ethernet chip on your shield.

It is simply a plate they gave me, I don’t know where it comes from, I can only read the name of the HanRun and “Mega compatible”. On the back it just doesn’t say anything. The micro is called Wiznet iEthernet 5100

The board its very similar to this one Módulo W5100 Ethernet Arduino Shield Web Server

That looks very similar if not identical to this: Ethernet shield module w5100 micro sd card slot for uno mega 2560 geekcreit for arduino - products that work with official arduino boards Sale - Banggood.com

Someone else has reported problems getting theirs to work, I will try and find the thread.

It seems that it will not work with my board then?

I’m sorry I can’t find the thread at the moment where problems with a W5100 shield were thought to be the problem. Of course it could just be a faulty shied did you get any links to software with the shield, or can you ask the supplier for any links to software that works with the shield?

Don’t worry and opted to buy a new shield and it works perfectly, thanks for the help

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.