SIM800 not registering with network

Hi,

I am using SIM800 powered by 5V/2A wall adapter with LM2596 to get 4.0V that the SIM800 needs. I added 1000u cap, just in case. Its connected to PC using USB to Serial.

The module has never been able to register with the network so far.
AT+CREG? always returns +CREG: 0,0.
Trying to register by sequence of of AT+CFUN=0 and AT+CFUN=1 always returns +CPIN: NOT INSERTED.

I ve used the supplied antenna as well as external antenna. AT+CSQ is always above 27.
I ve tried 3 sims, each of which work fine on a phone but never worked on SIM800
Can somebody point me to whats wrong?

Thanks and Regards,
WonderfulIOT

Two questions...

  1. The CPIN response is a concern.
  2. Where are you located? Is there still a 2G service to register with?

I am in India and its a 2G SIM. The network still supports 2G.

When tested with two old 2G only phones it worked on one phone but did not register on other.

The same SIM works in Neoway M590 but not on SIM800L. Can anyone pls explain this?

Thanks and Regards,
WonderfulIOT