SIM800C always Restarting with Atmega32U4

Hello,

In my custom board,we are interfacing SIM800C GSM with ATmega32U4microcontroller. we are powering sim800C with 3.93V.

problem::"For every 6seconds GSM is restarting that is indicated by status led "..We have checked supply voltage to the GSM with multimeter..It is showing 3.93V consistently without any undershoots in voltage in multimeter

The above problem is occurring only,when SIM is inserted ..if SIM not inserted ,it is consistently in ON state as intended.

So,We have tested GSM with supply voltage 4.3V from other regulated power source also..but showing same issue as usual..

please suggest me any solution for this problem.. :( :( :(

problem::"For every 6seconds GSM is restarting that is indicated by status led "..We have checked supply voltage to the GSM with multimeter..It is showing 3.93V consistently without any undershoots in voltage in multimeter

The multimeter won't show you short drops. Check the voltage with a scope.

The above problem is occurring only,when SIM is inserted ..if SIM not inserted ,it is consistently in ON state as intended.

That sounds like a current problem. How do you power the module? Separate power supply? Does that power source provide more than 2A as the datasheet requests?

Thanks for ur reply :) :)

Yes,we are giving power from LM2596HVS regulator(it can provide 3A current max)..

Please post a complete wiring diagram.

if your board looks like this

https://www.aliexpress.com/item/SIM800C-GSM-GPRS-module-STM32-microcontroller-51-equipped-with-Bluetooth-and-high-TTS/32728307475.html?spm=2114.search0104.3.8.7cdf7390muHHVW&ws_ab_test=searchweb0_0,searchweb201602_4_10065_10068_319_10059_10884_317_10887_10696_100031_321_322_10084_453_10083_454_10103_10618_10307_538_537_536,searchweb201603_51,ppcSwitch_0&algo_expid=0fdd8b39-a9f9-40d7-92a1-e1abd58af9e7-1&algo_pvid=0fdd8b39-a9f9-40d7-92a1-e1abd58af9e7

then you need 5V 2A to power it, i have one working like a charm registering my sim card to network,