SIM800C_V2 GSM trouble with serial communication.

Hello EveryOne,

I recently bought this device on bankGood:

But as far as I am , I’m still unable to make it dialogue with the arduino UNO…
I’ll put here what i’ve done and what I tried, hoping this will help some people whose have the same problem

The scheme as Follow

TX of GSM on RX (0) of UNO
RX on . GSM on the TX (1) of UNO
Vcc GSM on 5V UNO
GND GSM on GND UNO
V_M of GSM on 5V UNO

Linkin tries :
I tried either to connect via VBAT instead of Vcc , using a diode 1N4000 , but seems to get no launching of the module.
I tried to put V_M on ground to see if it will work better, but on GND TX RX of card shall be about 2.8V, not the same than UNO 4.7-5V . So it could damage the module… No more result…

In term of codes, I tried lots of scheme examples : SIM800L master, GSMSIM SMS, TINYGSM->Tool->debug.

The easiest one :

 */
#include <SoftwareSerial.h>

SoftwareSerial mySerial(0, 1); // RX, TX

void setup() {
  // Open serial communications and wait for port to open:
  Serial.begin(115200);
  while (!Serial) {
    ; // wait for serial port to connect. Needed for native USB port only
  }


  Serial.println("Goodnight moon!");

  // set the data rate for the SoftwareSerial port
  mySerial.begin(115200);
  mySerial.println("Hello, world?");
}

void loop() { // run over and over
  if (mySerial.available()) {
    Serial.write(mySerial.read());
  }
  if (Serial.available()) {
    mySerial.write(Serial.read());
  }
}

No rocket science… But no AT commande seems to be good. Tried different baudrate for each , 115200 and 9600… tried the TINYGSM diagnostics (thanks a lot to mister vshymanskyy :slight_smile: )
I tried to print in the loop but it seems that the code fail just after “Good morning moon”. No helloworld, and no loop().

The GSM example of arduino Lib , Tool → TestModem , says that my modem is Ok but I thinks this is completely different (I did not gone far in their library but as no Serial are implemented where I seen…)

I tried with or without SIMCard. I used a nanoSim , in both sens and moving it … no answer as well…

Ok then , what I’ve tried to resume :
-Different lib , sketch , from simple to complexe one.

  • V_M on 0 and 5V
    After my research, putting V_M on 5 force the TX RX to work with 5V as TTL (I am mistaken ?)

-Tried to invert TX RX (we never know (: hope makes live )

-Tried with nanoSim
Read Somewhere that if the Sim is not in the module, it will not work launch power… Seen anything that way on electrical scheme but… anyway.
-Tried with no Sim (especially with GSM->Tool->TestModem , as it’s written “no sims needed”)

-Tried to work on VBat with diode (As i will embed my baby, was a good trial… Even if I’d prefer to pass throught Arduino only to put down power using AVR power in another time).

-Tried to work on Vcc input of GSM with and without diode (Despair solutions…)

On the link of my buy, there is several comment saying that the device works properly… but mine just blink his D1 led once a second with no change (D1 led blink say “Not connected to network”)

-Checked every wire, checked every voltage. The only one which is strange is that VBAT does not work , no voltage at output. I think my UNO 0 1 pin work , I tried it as digital output and input.

Well well well… I’m in lack of solution here… I dunno if I miss something , or if my GSM board arrived broken, but…

Any solution ?

Ok , so seems to be natural matter with UNO serials as it's connected to USB with computer. Need to use cash memory to stock and stop USB when using pin 0 1 , or something like that... I dunno yet