SIM800L Ebay unit wont register

Hi All,

I hope someone can help.

This is what I am running:-

-Uno power from usb
-SIM800L via 3amp 4.2v PSU
-O2 2G Sim card

I run some basic code for a few days , able to send & receive SMS (this is all I need to do for my project).
after about a week the unit seems to become slower then wont register, I put this down to a faulty unit so ordered a new one from a different ebay seller.
All is well then a week or so later , it wont register.

Running AT+COPS=? returns the expected carriers (1,“O2”,“O2 -UK”,“23410”) but it doesn’t auto connect.

Are these boards this flaky or am a missing something.

Thanks

Please read this Thread: https://forum.arduino.cc/index.php?topic=306159.new#new

I think you destroyed the module, because the voltage of the serial pin was over 2.8V.

Thanks Kingside,

I ordered another sim800l , still the same issue even with the dividing resistors its still the same.

This is breaking me :frowning:

What is the status of the command AT+CREG? and the command AT+COPS?

I will finish my GPS Tracker first, then I can create a full circuit diagram for you. All the diagrams of the net are half true.