SIM800L no connections, often errors

I bought a SIM800L module for my project and started to experiment with it. However i am not able to send a sms or connect to the internet.
In various forums the error seems to be the power supply. I use a LiPo battery which supplies 3.7V with a max of 6A, so i think that should be ok, right? If not can i use a capacitor to stabilize the power during spikes in consumption and if so which capacity do you recommend.
Since this is my first time using the SIM800L it might also be a very stupid mistake. However i tried various methods and none succeeded.
In general if i use an AT-Command i will often get back "ERROR" and if i get an extended error report the reason is "no Reason", which i can only assume is some kind of default?
sometimes i will also get no response. I tried to set the baud rate to 9600 instead of auto, but no change.
if i run the AT+CSQ command i will nearly always get back 0,0. so i think that is at least part of the issue.

I read somewhere that a reset of the module can be detected by the Ring pin. So i added an LED. This is always Lit (meaning Ring is High) except sometimes where it quickly goes off and then on again, which i believe means a reset of the module. However this does not happen every time i get an error.

After a lot of commands it will send OK SMS Ready Call ready. Is this normal or also indicate a restart?

Other commands do usually work after a few tries, but anything that needs a connection does not work.

Does anyone knows what causes this issue, or how to figure out what is causing the problem?

This is an example code i use to try and send the message:

  mySerial.println("AT+CMGS=\"+49159xxxxx\"");//(i did replaced the xxx with my number)
  mySerial.print("TEST SIM MESSAGE V0.0.1");

Sometimes i get stuck with the response of the module being '>' after the CMGS command but no SMS gets send.
Any help would be greatly appreciated.