Simple Midi in....

So I'm trying to implement a midi in for the arduino (duemilanove with 328) and have tried this circuit and code

http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1187962258/0

but no luck I can get the status light to blink as if it is receiving something but can not get an LED to light no matter what I try.

also found this but doesn't seem as if anymore info was released.

http://www.thebasementscientist.com/2008/09/07/arduino-midi-shield-v2/

I'm new to the arduino and my first post here, any ideas???

Thanks!

This is a simple MIDI in project:-

http://www.thebox.myzen.co.uk/Hardware/Glockenspiel.html

Source code is posted too.

Thanks, though that is pretty much the same code, I'm just not sure if it's something I'm missing or if it's something different. I've tripple checked all my connections and code...

connect an LED instead of the Arduino and check if your optocoupler is working.

Maybe you use the wrong resistors or connected the wrong pins? And check the midi connector, maybe you use the wrong pins there.

I think it is a hardware problem as the software is very straight forward.

Maybe you want to post your schematics or a photo.

though that is pretty much the same code

Well it's pretty much doing the same thing.

When you say:-

I can get the status light to blink as if it is receiving something

What status light is this? Is it the one on PIN13 or is it the one on the TX/RX.

Make sure you are receiving something, by lighting the pin 13 LED on the serial available. If you have a MIDI output socket try printing back what you receive and displaying it on a MIDI monitor.

What are you using for your MIDI input source?