SimpleClient erro

Hi guys!
I'm new with arduino, and i'm having serious problems.

I'm using a wishield V2.0. The code is there:

/*

  • A simple sketch that uses WiServer to get the hourly weather data from LAX and prints
  • it via the Serial API
    */

#include <WiServer.h>

// Wireless configuration parameters ----------------------------------------
unsigned char local_ip[] = {192,168,1,2}; // IP address of WiShield
unsigned char gateway_ip[] = {192,168,1,1}; // router or gateway IP address
unsigned char subnet_mask[] = {255,255,255,0}; // subnet mask for the local network
char ssid[] = {"GVT-2906"}; // max 32 bytes
unsigned char security_type = 0; // 0 - open; 1 - WEP; 2 - WPA; 3 - WPA2

// WPA/WPA2 passphrase
const prog_char security_passphrase[] PROGMEM = {"6103000297"}; // max 64 characters

// WEP 128-bit keys
prog_uchar wep_keys[] PROGMEM = {
0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07, 0x08, 0x09, 0x0a, 0x0b, 0x0c, 0x0d, // Key 0
0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, // Key 1
0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, // Key 2
0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00 // Key 3
};

// setup the wireless mode; infrastructure - connect to AP; adhoc - connect to another WiFi device
#define WIRELESS_MODE_INFRA 1
#define WIRELESS_MODE_ADHOC 2
unsigned char wireless_mode = WIRELESS_MODE_INFRA;
unsigned char ssid_len;
unsigned char security_passphrase_len;
// End of wireless configuration parameters ----------------------------------------

// Function that prints data from the server
/void printData(char data, int len) {

// Print the data returned by the server
// Note that the data is not null-terminated, may be broken up into smaller packets, and
// includes the HTTP header.
Serial.print("printData was called\n");

for(int i=0; i<len; i++){
Serial.print(data*);*

  • }*

// while (len-- > 0) {
// Serial.print(*(data++));
// }

  • Serial.print("Did printData retrieve weather data above this sentence?\n");*
    }*/
    // Function that prints data from the server
    void printData(char* data, int len) {

  • // Print the data returned by the server*

  • // Note that the data is not null-terminated, may be broken up into smaller packets, and*

  • // includes the HTTP header.*

  • Serial.print("printData was called\n"); *

  • for(int i=0; i<len; i++){*
    _ Serial.print(data*);_
    _
    }*_

Serial.print("The value of len is: ");
* Serial.print(len);*
* Serial.print("\n"); *

* Serial.print("Did printData retrieve weather data above this sentence?\n");*
}
*// IP Address for www.weather.gov *
uint8 ip[] = {140,90,113,200};
// A request that gets the latest METAR weather data for LAX
GETrequest getWeather(ip, 80, "www.weather.gov", "/data/METAR/KLAX.1.txt");
void setup() {
* // Enable Serial output and ask WiServer to generate log messages (optional)*
* Serial.begin(9600);*

* // Initialize WiServer (we'll pass NULL for the page serving function since we don't need to serve web pages)*
* Serial.print("Initiating WiServer\n");*
* WiServer.init(NULL); *
* WiServer.enableVerboseMode(true);*
* Serial.print("WiServer initiated. \n"); *

* // Have the processData function called when data is returned by the server*

* getWeather.setReturnFunc(printData);*
}
// Time (in millis) when the data should be retrieved
long updateTime = 0; //1000 millis = 1 second
int counter = 1;

void loop(){

* // Check if it's time to get an update*
* if (millis() >= updateTime) {*
* getWeather.submit(); *
* // Get another update one hour from now*
_ //updateTime += 1000 * 60 * 60;
* // Get another update 30 seconds from now*
updateTime += 1000 * 30;_

* Serial.print("Loop #");*
* Serial.print (counter);*
* Serial.print (" complete.\n");*
* counter = counter + 1;*
* }*

* // Run WiServer*
* WiServer.server_task();*

* delay(10);*
}
But, when i open the serial monitor, i only get this:
Initiating WiServer
WiServer initiated.
Loop #1 complete.
Loop #2 complete.
Ended connection with www.weather.gov
printData was called
The value of len is: 0
Did printData retrieve weather data above this sentence?
Loop #3 complete.
Loop #4 complete.
Ended connection with www.weather.gov
printData was called
The value of len is: 0
Did printData retrieve weather data above this sentence?
"Len" isn't changing.
Can anybody help?