Since firmware upgrade inserting SD card causes Yun to vanish off the network..

i have formatted it twice in case, the SD worked fine pre firmware update so why now does inserting the SD card cause it to black out. I can see if via USB to write to it but also note that serial logging shows no output - related issue?

When you say "vanish off" you mean you can no longer access it through network or the yun can no longer access internet?
What do you do (please type or describe the exact commands/actions you're taking) and what happens to make you saying it's not working?

As in lose it totally, no SSH, no 192.168.1.3 & no USB serial via IDE - i can use IDE to upload a sketch and all is fine but if i hit the monitor no serial output.

Remove either ( i tried a new 2gb SD ) card and power cycle and its all back fully functional - insert SD back in and it vanishes again until i remove it and power cycle it again.

So strange, two different SD cards now..

It would be nice to:

  • remove sd card
  • upload yunserialterminal
  • open serial monitor
  • press yun rst button (near the leds)
  • insert sd card
  • watch is something is printed
  • press yun rst button
  • see what get printed now
  • copy the whole output into a file and attach it to this topic