"Size_t" does not Name a type

I'm a noob please pity.

Ive been using IDE for a couple days now with no problems , Today I tried compiling the same file I have many times over and i get a huge error list of files with something wrong with 'size_t' I have not updated IDE or changed the file in any significant way.
I have tried , reinstalling ide, reinstalling files for my board, compiling different files. Been searching Google for ages , please help.

or changed the file in any significant way

So you did change it and more than likely made a mistake :wink:

Please post your sketch.

If you haven't done so yet, please read How to use this forum - please read. - Installation & Troubleshooting - Arduino Forum, specifically point #7 about posting code.

If it's too big (9000 characters limit per post), attach.
If it consists of multiple tabs, zip it and attach.

Please post (clickable) links to 3rd party libraries (anything that is not in the standard install).

Please provide details about the board that you're compiling for.