Sketch appear to upload successfully but not do anything.

I have read and tried everything on the troubleshooting page but still will not load.
I have 2 UNO boards and have Arduino soft ware on both my laptop d desktop and have no luck loading my sketch, I have even tried the basic "Blink", no load, although it indicates it has loaded successfully.
Board and com port, in tools, correct. Both computers recognize the board.
I have used several cords, no help.
All have worked successfully in the past.

What now!!!
Please help, totally lost.
I should mention I am new at this Adruino stuff.

Can you enable Verbose upload in preferences and post the output that it generates?

Also, does the LED work? Press reset button - it should blink quickly a few times (that's the bootloader blinking it to let you know that the bootloader is running)

Yes the power indicator (green LED) is on and the yellow (13) LED is on but neither the RX or the TX blink when loading the sketch as they have done in the past.
I have loaded a "object avoiding" sketch last week and it works great but then the next time I tried to load nothing but the program indicates it has loaded.

Does the Loopback test work?

Did your last sketch bombard the serial port with messages, or otherwise drive the D0/D1 lines?

No nothing comes back.
Yes the light blinks a few times when I reset.

Operator problem.
Tanks for all you help.