sketch not uploading

I've been having this issue since my laptop crashed. I've deleted and reinstalled everything several times and get this message no matter what sketch i try to upload. Arduino: 1.8.13 (Windows 7), Board: "Arduino Uno"

Sketch uses 8082 bytes (25%) of program storage space. Maximum is 32256 bytes.

Global variables use 279 bytes (13%) of dynamic memory, leaving 1769 bytes for local variables. Maximum is 2048 bytes.

avrdude: ser_open(): can't open device "\.\COM7": The system cannot find the file specified.

Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Make sure you have selected the port of your Arduino board from the Tools > Port menu.

Sometimes the port will be labeled with the board name in the menu. Other times it will not. If you don’t know which port is your Arduino board, you can find it like this:

  • Unplug your Arduino board from the computer.
  • Tools > Port
  • Note the ports, if any, listed in the menu.
  • Close the Tools menu. The ports list is only updated when the Tools menu is re-opened, so this step is essential.
  • Plug your Arduino board into the computer.
  • Tools > Port - The new port listed in the menu is your Arduino board.

The port number changed from 7 to 10 even though i didn't change anything, but now it works, weird. Thanks

You're welcome. I'm glad to hear it's working now. Enjoy!
Per

Conceal-Pro:
The port number changed from 7 to 10 even though i didn't change anything, but now it works, weird. Thanks

You don't have to do anything, Windows does it for you :smiley:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.