Sketch upload error: avrdude: stk500_getsync(): not in sync: resp=0x00

Hi there,

I have read a lot of similar topics about this problem, but none have helped.

I have tried a different Arduino board, a different cable, I have re-downloaded the software and I have re-installed the drivers.

I originally used an Arduino Uno SMD, but am now using the Arduino Uno R3, which uses ATmega16U2.

I have double checked that the correct com port is being used and that the correct board is selected.

When the USB is connected to the Arduino, the “on” light appears is on and so another light with an “L” next to it. Pressing the reset button doesn’t make the lights blink like they used to.

Up until about a week ago, with my previous board, everything was working fine.

Can anyone help me with a solution?

Also, I have tried the "loop-back test". It works as it is supposed to.

After the "loop-back test", I attempted to upload a sketch again and this is what i received:

C:\Program Files\Arduino\hardware\tools\avr\bin\avr-ar: unable to rename 'core.a'; reason: File exists Binary sketch size: 3,578 bytes (of a 32,256 byte maximum) avrdude: stk500_getsync(): not in sync: resp=0x00

Try burning bootloader again, use the uno as ISP programmer.

I have tried that. I get the exact same error:

I replaced the Arduino and everything worked. Either the bootloader hadn't been burned to the chip or the chip was faulty.