Sketch upload issues

Hi All,

I'm very new to the Arduino and having some trouble getting my sketch to upload (see error code below). The Arduino I have purchased is a Franzis ATMega 168 which came as a starter kit. I have checked the obvious things below.

  • Selected Mega 168 board selected on sketch software
  • Checked com port on sketch software corresponds with the one on my comps device manager (com5)
  • Clicked on board info to see if sketch software can see my board which it can
  • Tried selecting following board options (geuino mega or mega 2560) and mega ADK

If anyone could provide me with some advise here it would be greatly appreciated.

Thanks

Caz

Arduino: 1.8.7 (Windows 10), Board: "Arduino/Genuino Mega or Mega 2560, ATmega1280"

Sketch uses 1486 bytes (1%) of program storage space. Maximum is 126976 bytes. Global variables use 9 bytes (0%) of dynamic memory, leaving 8183 bytes for local variables. Maximum is 8192 bytes. avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x27 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x27 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x27 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x27 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x27 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x27 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x27 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x27 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x27 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x27 Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

This report would have more information with "Show verbose output during compilation" option enabled in File -> Preferences.

Arduino: 1.8.7 (Windows 10), Board: "Arduino/Genuino Mega or Mega 2560, ATmega1280"

You have a board with a 168P processor but try to compile and upload to a Mega with a 1280 processor.

I did some looking based on what sterretje said, and I found that the Arduino Diecimila uses the ATMega168.

Once you select the Arduino Diecimila, it gives you the option to select the ATMega168 processor.

That being said, I do not know if that will work for you and for all I know it could cause bad problems. So, lets ask the expert first: Sterretje, will this work for bosh82?

I did find a PDF on the web yesterday for Franzis stuff (can’t find it back); I think that bosh82 needs to read the documentation that came with his kit.

I’m not an expert :wink: It might depend on the bootloader that’s on the board. But any board that refers to 168 is worth a try.